X
點擊此處開啟此網站的行動版。
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

技術支援討論區

certificate error

已張貼

When I go to one of our development sites, I get this error: Secure connection failed An error occurred during a connection to xxx.xxx.com Peer's certificate has an invalid signature (Error code: sec_error_bad_signature) . I do not have the option to add an excpetion anymore, but we used to be able to navigate there. I'm running 3.6.13.

When I go to one of our development sites, I get this error: Secure connection failed An error occurred during a connection to xxx.xxx.com Peer's certificate has an invalid signature (Error code: sec_error_bad_signature) . I do not have the option to add an excpetion anymore, but we used to be able to navigate there. I'm running 3.6.13.

額外的系統細節

受影響的站台

https://

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Google Update
  • Shockwave Flash 10.1 r82
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • 4.0.51204.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Version 1.1.5, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/

應用程式

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

更多資訊

dj.si 0 個解決方法 4 個答案

I'm also using Firefox 3.6.13 and had the same problem. This issue can be solved simply by changing Firefox's configuration - it's NOT necessary to install any Firefox add-ons to do this, even though internet searches will list various add-ons for fixing this problem.

This is how it's done:

- Open a new Firefox window, and type this into the address/URL:

    about:config


- You'll probably see a warning that changing the config can be dangerous. Click the button to accept the warning and proceed, but BE CAREFUL from here on!

- A table will appear showing various Firefox settings ("Preference Names") and their current values.

- In the Filter box type: broswer.xul

- There should now be a shorter list of settings, including one named browser.xul.error_pages.expert_bad_cert with a value of false.

- Right-click on browser.xul.error_pages.expert_bad_cert and select Toggle. The value will change to true.

- Exit completely from Firefox (i.e. close all windows), and then restart it.

The next time you visit a secure site where there is a problem with its certificate, the certificate error page will show a button that allows the site to be added as an exception, and then you'll be able to proceed and view the site.

WARNING: If Firefox warns that there is a problem with a site's certificate, proceed only if:

a) you are 100% certain that it's safe, or

b) you accept the risks!

Certificate warnings should definitely NOT appear on any sites dealing with money/transactions, e.g. online shopping, online banking, etc.

Hope this helps!

Si

I'm also using Firefox 3.6.13 and had the same problem. This issue can be solved simply by changing Firefox's configuration - it's '''NOT''' necessary to install any Firefox add-ons to do this, even though internet searches will list various add-ons for fixing this problem. This is how it's done: - Open a new Firefox window, and type this into the address/URL: about:config - You'll probably see a warning that changing the config can be dangerous. Click the button to accept the warning and proceed, but '''BE CAREFUL''' from here on! - A table will appear showing various Firefox settings ("''Preference Names''") and their current values. - In the Filter box type: ''broswer.xul'' - There should now be a shorter list of settings, including one named ''browser.xul.error_pages.expert_bad_cert'' with a value of ''false''. - Right-click on ''browser.xul.error_pages.expert_bad_cert'' and select ''Toggle''. The value will change to ''true''. - Exit completely from Firefox (i.e. close '''all''' windows), and then restart it. The next time you visit a secure site where there is a problem with its certificate, the certificate error page will show a button that allows the site to be added as an exception, and then you'll be able to proceed and view the site. '''WARNING:''' If Firefox warns that there is a problem with a site's certificate, proceed only if: a) you are 100% certain that it's safe, or b) you accept the risks! Certificate warnings should definitely '''NOT''' appear on any sites dealing with money/transactions, e.g. online shopping, online banking, etc. Hope this helps! Si
pamjustice 0 個解決方法 1 個答案

This doesn't always seem to work. I still get the same error and there is no button to allow me to add this site as an exception I am using version 3.6.18 and followed these instructions carefully but the same error page described here comes up when I tried to access my https site.

This doesn't always seem to work. I still get the same error and there is no button to allow me to add this site as an exception I am using version 3.6.18 and followed these instructions carefully but the same error page described here comes up when I tried to access my https site.

由 pamjustice 於 修改

dj.si 0 個解決方法 4 個答案

I am now using v3.6.18 as well. I have just tested this again, and it's working fine. I would suggest trying the following:

- Make sure every Firefox window has been closed

- Start Firefox in Safe Mode: Click Start -> Programs -> Mozilla Firefox -> Mozilla Firefox (Safe Mode)

- Go to about:config and ensure that the value of browser.xul.error_pages.expert_bad_cert is set to true, as described above

- Close the Firefox window and reboot your computer

- Start Firefox in Safe Mode again and check the setting of browser.xul.error_pages.expert_bad_cert - hopefully it will still be true

- Try opening the https page that you want to access and see if the button to add an exception is now available

- If that works, close the Firefox window, then restart Firefox normally (i.e. not in Safe Mode) and try the https page again

Hope that helps!

Si

I am now using v3.6.18 as well. I have just tested this again, and it's working fine. I would suggest trying the following: - Make sure every Firefox window has been closed - Start Firefox in Safe Mode: Click ''Start'' -> ''Programs'' -> ''Mozilla Firefox'' -> ''Mozilla Firefox (Safe Mode)'' - Go to ''about:config'' and ensure that the value of ''browser.xul.error_pages.expert_bad_cert'' is set to ''true'', as described above - Close the Firefox window and reboot your computer - Start Firefox in Safe Mode again and check the setting of ''browser.xul.error_pages.expert_bad_cert'' - hopefully it will still be true - Try opening the https page that you want to access and see if the button to add an exception is now available - If that works, close the Firefox window, then restart Firefox normally (i.e. not in Safe Mode) and try the https page again Hope that helps! Si
Phil 0 個解決方法 1 個答案

Frustrating, tried all the above to no avail, but in the end after some searching found I had to import a versign certificate: https://knowledge.verisign.com/support/ssl-certificates-support/index?page=content&id=AR1514

Frustrating, tried all the above to no avail, but in the end after some searching found I had to import a versign certificate: https://knowledge.verisign.com/support/ssl-certificates-support/index?page=content&id=AR1514
talamortis 0 個解決方法 1 個答案

Make sure your date and time is correct i had the same problem and thats how i fixed this

Make sure your date and time is correct i had the same problem and thats how i fixed this