搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How do I get the error console to quit popping up?

  • 8 回覆
  • 331 有這個問題
  • 9228 次檢視
  • 最近回覆由 B52GUNS

more options

My error console keeps popping up when I open Firefox or when a pop-up occurs but its getting really annoying because it has never done that before. Please tell me how do i get it to quit popping up.

被選擇的解決方法

Do you have any mouse gesture extensions installed?

You can see the installed Firefox extensions in "Tools > Add-ons > Extensions".

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
從原來的回覆中察看解決方案 👍 14

所有回覆 (8)

more options

That is usually caused by a setting in the Web Developer Toolbar. Do you have the Web Developer extension installed?

more options

Some mouse gesture extensions have also been reported to cause this issue.

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

where can i find the wed devoloper toolbar?

more options

選擇的解決方法

Do you have any mouse gesture extensions installed?

You can see the installed Firefox extensions in "Tools > Add-ons > Extensions".

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
more options

If you have the Web Developer Toolbar installed, do the following to prevent the Error Console from popping up:

(If the Web Developer toolbar is not visible, you can also access the same parameters via the Tools/Web Developer/Options/Options menus in the Firefox menu bar).

1. Click on the "Options" icon in the Web Developer toolbar.

2. Click on "Options" in the drop-down menu.

3. Click on the "Miscellaneous" icon

4. Make sure that all the boxes are unchecked in the "Warnings and Errors" menu box.

Now the Error console will stop popping up when you go to a site. You can always check the boxes to display the Error Console later if needed.

由 strat5459 於 修改

more options

I disabled All-in-One mouse gestures (use FireGestures instead) and this annoying error console pop-up problem is solved.

more options

Thanks, strat5459! This is the answer to this issue... at least it was for me. Many thanks!

There should be a disclaimer or warning with the Web Developer Toolbar about this happening. It is baffling, completely counter-intuitive, and renders Firefox almost unusable until you figure it out. (or come here.... : )

TC

由 Tomc50 於 修改

more options

Had this problem of "error console" popping up. Through process of elimination, the add on "FoxLocation", vrs 0.0.0.6 with the "Enable Debug" checked was causing the problem. Unchecked the "Enable Debug", and all was fine. Sounds strange, but it is true.

TSgt R.M. Johnson