X
點擊此處開啟此網站的行動版。

技術支援討論區

mailto function does not work

已張貼

Whenever I click on a mailto: link, either nothing happens or, in some instances, a new blank tab will appear. I have Outlook set as my email client, and the program is running. Other browsers, IE and Chrome, link out to Outlook just fine, only Firefox (3.6.11) has this problem.

Whenever I click on a mailto: link, either nothing happens or, in some instances, a new blank tab will appear. I have Outlook set as my email client, and the program is running. Other browsers, IE and Chrome, link out to Outlook just fine, only Firefox (3.6.11) has this problem.

額外的系統細節

這發生了

每當開啟 Firefox 的時候

已安裝的外掛程式

  • Office Plugin for Netscape Navigator
  • Adobe PDF Plug-In For Firefox and Netscape 8.2.5
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.1 r85
  • 4.0.50917.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • Google Update
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

應用程式

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11

更多資訊

Application Basics
Name
Firefox
Version
3.6.11
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Biobar
2.0.1
false
{3e559c3c-4aad-4168-bd47-e1056298df8e}
Download Statusbar
0.9.7.2
false
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
DownloadHelper
4.8.1
false
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
FireShot
0.85
false
{0b457cAA-602d-484a-8fe7-c1d894a011ba}
Gmail Manager
0.6
false
{582195F5-92E7-40a0-A127-DB71295901D7}
Java Console
6.0.11
true
{CAFEEFAC-0016-0000-0011-ABCDEFFEDCBA}
Java Console
6.0.15
true
{CAFEEFAC-0016-0000-0015-ABCDEFFEDCBA}
Java Console
6.0.17
true
{CAFEEFAC-0016-0000-0017-ABCDEFFEDCBA}
Microsoft .NET Framework Assistant
1.2.1
false
{20a82645-c095-46ed-80e3-08825760534b}
Java Console
6.0.19
true
{CAFEEFAC-0016-0000-0019-ABCDEFFEDCBA}
Java Console
6.0.22
true
{CAFEEFAC-0016-0000-0022-ABCDEFFEDCBA}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days
7
browser.history_expire_days.mirror
7
browser.history_expire_days_min
5
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
2
browser.places.updateRecentTagsUri
false
browser.startup.homepage
http://nytimes.com/
browser.startup.homepage_override.mstone
rv:1.9.2.11
dom.disable_open_during_load
false
dom.max_chrome_script_run_time
0
extensions.lastAppVersion
3.6.11
network.cookie.prefsMigrated
true
network.http.proxy.version
1.0
network.protocol-handler.expose.mailto
true
network.protocol-handler.external.mailto
false
places.last_vacuum
1282936128
print.print_printer
Phaser 8560DN-5 PS
print.printer_GreenPrint_PDF.print_bgcolor
true
print.printer_GreenPrint_PDF.print_bgimages
true
print.printer_GreenPrint_PDF.print_command
print.printer_GreenPrint_PDF.print_downloadfonts
false
print.printer_GreenPrint_PDF.print_edge_bottom
0
print.printer_GreenPrint_PDF.print_edge_left
0
print.printer_GreenPrint_PDF.print_edge_right
0
print.printer_GreenPrint_PDF.print_edge_top
0
print.printer_GreenPrint_PDF.print_evenpages
true
print.printer_GreenPrint_PDF.print_footercenter
print.printer_GreenPrint_PDF.print_footerleft
print.printer_GreenPrint_PDF.print_footerright
print.printer_GreenPrint_PDF.print_headercenter
print.printer_GreenPrint_PDF.print_headerleft
&U
print.printer_GreenPrint_PDF.print_headerright
&D
print.printer_GreenPrint_PDF.print_in_color
true
print.printer_GreenPrint_PDF.print_margin_bottom
0.5
print.printer_GreenPrint_PDF.print_margin_left
0.400000005960464
print.printer_GreenPrint_PDF.print_margin_right
0.400000005960464
print.printer_GreenPrint_PDF.print_margin_top
0.5
print.printer_GreenPrint_PDF.print_oddpages
true
print.printer_GreenPrint_PDF.print_orientation
0
print.printer_GreenPrint_PDF.print_pagedelay
500
print.printer_GreenPrint_PDF.print_paper_data
1
print.printer_GreenPrint_PDF.print_paper_height
11.00
print.printer_GreenPrint_PDF.print_paper_size_type
0
print.printer_GreenPrint_PDF.print_paper_size_unit
0
print.printer_GreenPrint_PDF.print_paper_width
8.50
print.printer_GreenPrint_PDF.print_reversed
false
print.printer_GreenPrint_PDF.print_scaling
0.80
print.printer_GreenPrint_PDF.print_shrink_to_fit
false
print.printer_GreenPrint_PDF.print_to_file
false
print.printer_GreenPrint_PDF.print_unwriteable_margin_bottom
0
print.printer_GreenPrint_PDF.print_unwriteable_margin_left
0
print.printer_GreenPrint_PDF.print_unwriteable_margin_right
0
print.printer_GreenPrint_PDF.print_unwriteable_margin_top
0
print.printer_Phaser_8560DN-5_PS.print_bgcolor
true
print.printer_Phaser_8560DN-5_PS.print_bgimages
true
print.printer_Phaser_8560DN-5_PS.print_command
print.printer_Phaser_8560DN-5_PS.print_downloadfonts
false
print.printer_Phaser_8560DN-5_PS.print_edge_bottom
0
print.printer_Phaser_8560DN-5_PS.print_edge_left
0
print.printer_Phaser_8560DN-5_PS.print_edge_right
0
print.printer_Phaser_8560DN-5_PS.print_edge_top
0
print.printer_Phaser_8560DN-5_PS.print_evenpages
true
print.printer_Phaser_8560DN-5_PS.print_footercenter
print.printer_Phaser_8560DN-5_PS.print_footerleft
print.printer_Phaser_8560DN-5_PS.print_footerright
print.printer_Phaser_8560DN-5_PS.print_headercenter
print.printer_Phaser_8560DN-5_PS.print_headerleft
&U
print.printer_Phaser_8560DN-5_PS.print_headerright
&D
print.printer_Phaser_8560DN-5_PS.print_in_color
true
print.printer_Phaser_8560DN-5_PS.print_margin_bottom
0.5
print.printer_Phaser_8560DN-5_PS.print_margin_left
0.400000005960464
print.printer_Phaser_8560DN-5_PS.print_margin_right
0.400000005960464
print.printer_Phaser_8560DN-5_PS.print_margin_top
0.5
print.printer_Phaser_8560DN-5_PS.print_oddpages
true
print.printer_Phaser_8560DN-5_PS.print_orientation
0
print.printer_Phaser_8560DN-5_PS.print_pagedelay
500
print.printer_Phaser_8560DN-5_PS.print_paper_data
1
print.printer_Phaser_8560DN-5_PS.print_paper_height
11.00
print.printer_Phaser_8560DN-5_PS.print_paper_size_type
0
print.printer_Phaser_8560DN-5_PS.print_paper_size_unit
0
print.printer_Phaser_8560DN-5_PS.print_paper_width
8.50
print.printer_Phaser_8560DN-5_PS.print_reversed
false
print.printer_Phaser_8560DN-5_PS.print_scaling
0.80
print.printer_Phaser_8560DN-5_PS.print_shrink_to_fit
true
print.printer_Phaser_8560DN-5_PS.print_to_file
false
print.printer_Phaser_8560DN-5_PS.print_unwriteable_margin_bottom
0
print.printer_Phaser_8560DN-5_PS.print_unwriteable_margin_left
0
print.printer_Phaser_8560DN-5_PS.print_unwriteable_margin_right
0
print.printer_Phaser_8560DN-5_PS.print_unwriteable_margin_top
0
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.offlineApps
true
privacy.cpd.siteSettings
true
privacy.item.offlineApps
true
privacy.popups.showBrowserMessage
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.promptOnSanitize
false
privacy.sanitize.sanitizeOnShutdown
true
security.enable_ssl2
true
security.enable_tls
false
security.warn_viewing_mixed
false

the-edmeister
  • Top 25 Contributor
  • Moderator
5406 個解決方法 40244 個答案
http://support.mozilla.com/en-US/kb/Changing+the+e-mail+program+used+by+Firefox

提出問題者

Outlook is already set up as my default program for e-mail, both for Firefox and my System. All other browsers can do the mailto link out trick with no problem. My recent update may be corrupted/damaged or some setting is wrong.

Outlook is already set up as my default program for e-mail, both for Firefox and my System. All other browsers can do the mailto link out trick with no problem. My recent update may be corrupted/damaged or some setting is wrong.
cor-el
  • Top 10 Contributor
  • Moderator
17538 個解決方法 158577 個答案

有幫助的回覆

Did you check the Mailto settings in Tools > Options > Applications ?


You can look at the network.protocol-handler.external.mailto prefs on the about:config page.
If network.protocol-handler.external.mailto prefs are user set (bold) then right-click and Reset them to the default value.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

Did you check the Mailto settings in Tools > Options > Applications ? ---- You can look at the network.protocol-handler.external.mailto prefs on the about:config page.<br /> If network.protocol-handler.external.mailto prefs are user set (bold) then right-click and Reset them to the default value. To open the <i>about:config</i> page, type <b>about:config</b> in the location (address) bar and press the "<i>Enter</i>" key, just like you type the url of a website to open a website.<br /> If you see a warning then you can confirm that you want to access that page.<br />
Steve to the H 0 個解決方法 1 個答案

有幫助的回覆

"Did you check the Mailto settings in Tools > Options > Applications ?

You can look at the network.protocol-handler.external.mailto prefs on the about:config page. If network.protocol-handler.external.mailto prefs are user set (bold) then right-click and Reset them to the default value.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website. If you see a warning then you can confirm that you want to access that page.


'This worked great! This issue was pissing me off, I was familiar with about:config page but this shit had me stumped! Thanks cor-el '

''"Did you check the Mailto settings in Tools > Options > Applications ? You can look at the network.protocol-handler.external.mailto prefs on the about:config page. If network.protocol-handler.external.mailto prefs are user set (bold) then right-click and Reset them to the default value. To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website. If you see a warning then you can confirm that you want to access that page.'' '''This worked great! This issue was pissing me off, I was familiar with about:config page but this shit had me stumped! '''Thanks cor-el ''''''
clintondyches 0 個解決方法 6 個答案

Yes, I'm having this problem, too. But I'm on a Mac, running Lion and Firefox 11. My mailto client is set to Outlook (in Office 2011 for Mac) yet Firefox just opens a blank tab. In Firefox 10.x, it tried to open my gmail account. What's up - all my settings are correct, yet my mailto client is simply ignored: opening the blank tab.

Yes, I'm having this problem, too. But I'm on a Mac, running Lion and Firefox 11. My mailto client is set to Outlook (in Office 2011 for Mac) yet Firefox just opens a blank tab. In Firefox 10.x, it tried to open my gmail account. What's up - all my settings are correct, yet my mailto client is simply ignored: opening the blank tab.
jonadelman 0 個解決方法 10 個答案

You know, my problem is that the Mailto icon in Options>Applications is that funky unrecognized icon. it's not that it's not there, or that it's not set, it's totally unrecognized. A bunch of other applications are also unrecognized, like irc, ircs, magnet and webcal. Also, most of the files in my profile folder are unrecognizable too. What's the story? What I gotta do?

You know, my problem is that the Mailto icon in Options>Applications is that funky unrecognized icon. it's not that it's not there, or that it's not set, it's totally unrecognized. A bunch of other applications are also unrecognized, like irc, ircs, magnet and webcal. Also, most of the files in my profile folder are unrecognizable too. What's the story? What I gotta do?
clintondyches 0 個解決方法 6 個答案

network.protocol-handler.external.mailto

Hey - that worked! I've been asking this question for months and now finally found an answer. Thanks so very much! It works on a Mac running Lion, Firefox 11, and Outlook, at least. No more trying to load GMAIL or opening blank tabs. I owe you a latte, my friend.

network.protocol-handler.external.mailto Hey - that worked! I've been asking this question for months and now finally found an answer. Thanks so very much! It works on a Mac running Lion, Firefox 11, and Outlook, at least. No more trying to load GMAIL or opening blank tabs. I owe you a latte, my friend.
b53fj 0 個解決方法 2 個答案

I've tried everything - fixed the 'network.protocol-handler.external.mailto' thingie and still didn't work. BTW, in my 'Tools > Options > Applications' I don't have Gmail - just Googlemail - I suppose it's the same thing? Anyway Googlemail doesn't work. Tried 'Use handlemailto' which uses "GmailDefaultMaker.exe" and it worked!!

I've tried everything - fixed the 'network.protocol-handler.external.mailto' thingie and still didn't work. BTW, in my 'Tools > Options > Applications' I don't have Gmail - just Googlemail - I suppose it's the same thing? Anyway Googlemail doesn't work. Tried 'Use handlemailto' which uses "GmailDefaultMaker.exe" and it worked!!
clintondyches 0 個解決方法 6 個答案

What OS are you running? Are you running Firefox 12? The "about:config" - "network.protocol-handler.external.mailto" was set to bold (false) and I just double-clicked it, setting it to "true" and my mailto opens Outlook all the time now.

What OS are you running? Are you running Firefox 12? The "about:config" - "network.protocol-handler.external.mailto" was set to '''bold''' (false) and I just double-clicked it, setting it to "true" and my mailto opens Outlook all the time now.
b53fj 0 個解決方法 2 個答案

I'm running W7 and Waterfox 11.0 (the 64bit version of Firefox). When I was using FFox 11.0 I had "network.protocol-handler.external.mailto" true, didn't work - changed to false, still didn't work. Same in Waterfox. It seems the 'Use handlemailto' which uses "GmailDefaultMaker.exe" was the only way I could fix it and this was a 'now I'll try anything' last ditch lucky guess that worked. Pure luck and guesswork but it works now. I've tried everything I've ever seen on these forums (fora?) and nothing else worked for me.

I'm running W7 and Waterfox 11.0 (the 64bit version of Firefox). When I was using FFox 11.0 I had "network.protocol-handler.external.mailto" true, didn't work - changed to false, still didn't work. Same in Waterfox. It seems the 'Use handlemailto' which uses "GmailDefaultMaker.exe" was the only way I could fix it and this was a 'now I'll try anything' last ditch lucky guess that worked. Pure luck and guesswork but it works now. I've tried everything I've ever seen on these forums (fora?) and nothing else worked for me.
D'Arcy Cain 0 個解決方法 6 個答案

I found a solution. It's sort of a "hold your nose the right way" solution but it worked for me when everything else failed. I went into preferences => applications and found the mailto entry. It was set to "Thunderbird (default)" but that wasn't working. I then set it to always ask. The next time I hit a mailto link it asked and I told it to use Thunderbird and remember my choice. After that FF worked the way I expected.

I found a solution. It's sort of a "hold your nose the right way" solution but it worked for me when everything else failed. I went into preferences => applications and found the mailto entry. It was set to "Thunderbird (default)" but that wasn't working. I then set it to always ask. The next time I hit a mailto link it asked and I told it to use Thunderbird and remember my choice. After that FF worked the way I expected.