搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Error msg: "there was a problem sending the command to the program" when using a FireFox shortcut

  • 18 回覆
  • 572 有這個問題
  • 3914 次檢視
  • 最近回覆由 bigcolblue

more options

This happens only when I use a shortcut to invoke Firefox. I am running Windows 7 professional. The Firefox window opens after the error message occurs, so I would classify this as an annoyance. Several help postings mention removing "ddeexec" from Firefox registry entries. This worked for a while (it seems to be related to Firefox updates) but now no longer works: ddeexec is removed but the error message still occurs.

被選擇的解決方法

I found a Win 7 (x64) fix based on two observations:

1. The timeout does not occur if Firefox is already running.

2. There are (at least) two kinds of shortcuts: Application and URL. When Firefox is the default browser, URL shortcuts get a timeout message. An application shortcut to Firefox runs with no problems.

Follow these three steps to create a new shortcut that runs Firefox with the URL as a command:

1. Create an Application shortcut by either copying an existing shortcut, or right click on the desktop, select New | Shortcut, and browse to the location of Firefox.exe.

2. Next right click to open the new shortcut Properties. On the Shortcut tab you will find:

Target: "C:\Program Files (x86)\Mozilla Firefox\Firefox.exe"

Start in: "C:\Program Files (x86)\Mozilla Firefox"

3. Copy the URL, enter a space following the Target quotes, and paste the URL It should look like this:

Target: "C:\Program Files (x86)\Mozilla Firefox\Firefox.exe" http://postini.com

I used a short URL for this example to fit on one line, but useful commands can be much longer; e.g.:

https://login.postini.com/exec/login?email=youraccount@gmail.com

The second example opens a Postini spam filter login window and enters your email address for you. Below is a screenshot of a Properties Shortcut tab showing the middle of the target line where the Firefox path ends, and the URL begins.

-- Jim

從原來的回覆中察看解決方案 👍 4

所有回覆 (18)

more options

My problem was resolved when I disabled the FoxyProxy add-on that I had installed. Someone mentioned this in another forum and it worked for me.

more options

In my case, the problem was coming from the FoxClock extension. Once I disabled it, it worked fine.

Olivier

more options

Yes, that was the problem. I removed FoxyProxy and everything worked. BTW, it came back when I added "GoodSearch". I suspect there is a general issue with addons, but that's speculation...

more options

選擇的解決方法

I found a Win 7 (x64) fix based on two observations:

1. The timeout does not occur if Firefox is already running.

2. There are (at least) two kinds of shortcuts: Application and URL. When Firefox is the default browser, URL shortcuts get a timeout message. An application shortcut to Firefox runs with no problems.

Follow these three steps to create a new shortcut that runs Firefox with the URL as a command:

1. Create an Application shortcut by either copying an existing shortcut, or right click on the desktop, select New | Shortcut, and browse to the location of Firefox.exe.

2. Next right click to open the new shortcut Properties. On the Shortcut tab you will find:

Target: "C:\Program Files (x86)\Mozilla Firefox\Firefox.exe"

Start in: "C:\Program Files (x86)\Mozilla Firefox"

3. Copy the URL, enter a space following the Target quotes, and paste the URL It should look like this:

Target: "C:\Program Files (x86)\Mozilla Firefox\Firefox.exe" http://postini.com

I used a short URL for this example to fit on one line, but useful commands can be much longer; e.g.:

https://login.postini.com/exec/login?email=youraccount@gmail.com

The second example opens a Postini spam filter login window and enters your email address for you. Below is a screenshot of a Properties Shortcut tab showing the middle of the target line where the Firefox path ends, and the URL begins.

-- Jim

由 JimHenrySB 於 修改

more options

That worked! I was also able to restore several of my favorite add-ins. Timing appears to have been the entire issue. Elegant and well-explained fix. Thanks!

more options

I have a hard time understanding your directions. I have a windows 7 x64 also. I would appreciate the help. Thanks

more options

Really annoying problem. Here is what I did (not claiming originality) in win7 x64: --> Control Panel --> Default Programs --> Associate a file type or protocol with a program --> in Name column find .url row and double-click --> set association to Firefox

In my case, the url association had been set to explorer. Hope this helps someone.

more options

Just installed the recommended update to 3.6.22 and now my hundreds if not thousands of URL, HTM, and HTML short-cuts do not work. Set associations to other browser and they work fine. Not sure what the update changed in regards to this (or restrictive security added), but it should be fixed.

more options

Any help on this annoying issue?

more options

I have this problem and it is the 7.01 version of Mozilla. I downloaded a older 7.0 version and it work fine so i suppose they will figure this out soon.....hope this helps...

more options

Thanks Rick ! Your suggestion worked ! "Really annoying problem. Here is what I did (not claiming originality) in win7 x64: --> Control Panel --> Default Programs --> Associate a file type or protocol with a program --> in Name column find .url row and double-click --> set association to Firefox In my case, the url association had been set to explorer. "

All I can add is to click on the "CURRANT DEFAULT" header to find Firefox and Internet Explorer defaults quicker. Then go to the URL extension (on left side of defaults list/page) and click on that Internet Explorer Default (.url) and click on change program which should bring up options to change it to. If you do not see Firefox listed then you need to "browse" to C:\Program Files (x86)\Mozilla Firefox and double click on the Firefox APPLICATION file and it should now be seen as an option to "change to" in the change to box.

Hope this helps!

Simply go to

more options

Thanks is_matrix. My problem was caused by version 7.01 as well. I upgraded to 8.0 beta and it went away. Thank God! It was either get this fixed or use IE!

由 mikekehrli 於 修改

more options

This just started with version 7 and now version 8. Version 6.0.2 worked just fine and still does. After I upgraded to version 7 and could not get this problem resolved, I went back to version 6.0.2. Now I see version 8 has the same problem. And it is a problem that needs to be corrected Why can't it be fixed? I can make the changes through control panel as described in previous posts BUT then the short cuts ALL have a Fire Fox icon and CAN NOT be changed from the properties selection. I can also make new short cuts that has fire fox in the command line and the url after that but what am I to do, create a new short cut for every url in my windows favorite menu? Come on Mozilla, get with the program and get this FIXED!!!!!!!!!!!!!!!!!!!!!!!!!!

I forgot to say that version 7 & 8 both work fine with win XP operating system.

由 Barney 於 修改

more options

Don't seem like this can be fixed so I went back to version 6.0.2 which works good.

I have Chrome now as my default browser and will not use fire fox until they fix it!

Chrome works great!

more options

OK folks, got it figured out. I uninstall FF 6.0.2 completely included bookmarks. Then I installed FF 8.0.1 and all is well and good! FF 8 works good for me now. I had imported FF bookmarks into Chrome so I had to export them from Chrome and then import them back to FF 8.

more options

FF 9 working great

more options

I have three simple add-ons that never pose problems. I could not open desktop links all day today. I did not recently upgrade and I am using v 3.6.

I closed FF and reopened it. That seemed to fix the problem, at least for now.

Firefox is always running. I have Win 7 (x 64). If it is not an add-on problem, which was not my situation, I do not think there is a solution. Is there?

more options

thanks for your advice, mine was set to explorer as well and once corrected, error has gone, hopefully for good