搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Entries meant for Queriac are going to Verizon "Search Assist" instead

  • 4 回覆
  • 2 有這個問題
  • 1524 次檢視
  • 最近回覆由 Noah

more options

The way my about:config is set up, all URL-bar entries that aren't formatted like a URL are instead sent to "http://queri.ac/lenoxus/X", where X is the entry. The result is that I can treat the awesomebar as a command line of sorts; for example, if I enter "fb", it redirects me to Facebook, and if I type "w chocolate", it searches Wikipedia for "chocolate". (Yes, I know Firefox has keyworded bookmarks, but Queriac allows me to easily synchronize those with other computers.)

I recently set up a wireless system for my house. The router gets input from a DSL modem which gets input from a Verizon phone line. There's a sudden new behavior going on: if the entry is not a URL and doesn't contain a space, the query is instead sent to a Verizon search engine thing called "Search Assist". I tried following Verizon's directions for turning this off (re-interpreting them for Mac 10.5), but the only result was to prevent all Web pages from loading.

In any case, it seems to me that there should be a way for the pattern to go Firefox -> Queriac-based-URL -> okay Verizon, please go to that Queriac page. How do I prevent Verizon from butting in and "trying to help" before Queriac gets a chance to receive the two- or three-letter data? Is there an about:config that could work?

For what it's worth, everything does still work fine if there's a space in the entry. If I type "w dragonfly", it will load this page, but if I only enter "w", it loads this one. So a current workaround is to type things like "fb x". I want the workaround-workaround.

由 Chris 於 修改

被選擇的解決方法

I had a similar problem with Verizon's page coming up instead of a Google search from the address bar. My solution was to edit the DNS server on the router to prevent their DNS Assist.

For Verizon specifically, the link is here - you just choose your equipment for directions: http://www22.verizon.com/Support/Residential/Internet/fiosinternet/troubleshooting/network/questionsone/99031.htm

I believe that if you search your ISP's page for "DNS assist" and maybe the words "opt out" you can find specific directions there. If their page doesn't help, Google for the ISP name and those terms.

Alternately, you can also use Google's Public DNS service or the Open DNS service - both provide alternate DNS servers you can input into your router.

https://developers.google.com/speed/public-dns/ http://www.opendns.com/home-solutions/

For the record, I had tried changing my PC's DNS settings, but the router was over-riding my searches, so I had to change them there. It was very easy.

從原來的回覆中察看解決方案 👍 0

所有回覆 (4)

more options

Another wrinkle to it I just noticed: The problem only happens when the entered text is one of my Queriac commands, but has no space-plus-more-text. So "fb" returns that Verizon page instead of Facebook, but "st" searches Google for "st" (this being the correct behavior for my Queriac account when it is given text that is not one of the commands). Curiouser and curiouser.

more options

Ah, I seem to have encountered the issue described in this Mozilla help page (oddly, the "French"-but-actually-English version showed up earlier in my Google searches on the subject):

https://support.mozilla.com/fr/kb/Les+recherches+sont+redirig%C3%A9es+vers+un+autre+site

The page says, among other useful things: If you are unable to opt out from your service provider, the following workarounds may help you retain the ability to search from the location bar: Only do multi-word searches from the Location bar. (etc.)

Okey-dokey, then.

(I also now get why Firefox has to send my one-word entries to Verizon instead of Queriac. It's because it can't tell, on its own, whether anything without a space is a valid URL.)

more options

FULLY SOLVED! This extension, NoRedirect, does the trick:

https://addons.mozilla.org/en-US/firefox/addon/11787/

Yay!

more options

選擇的解決方法

I had a similar problem with Verizon's page coming up instead of a Google search from the address bar. My solution was to edit the DNS server on the router to prevent their DNS Assist.

For Verizon specifically, the link is here - you just choose your equipment for directions: http://www22.verizon.com/Support/Residential/Internet/fiosinternet/troubleshooting/network/questionsone/99031.htm

I believe that if you search your ISP's page for "DNS assist" and maybe the words "opt out" you can find specific directions there. If their page doesn't help, Google for the ISP name and those terms.

Alternately, you can also use Google's Public DNS service or the Open DNS service - both provide alternate DNS servers you can input into your router.

https://developers.google.com/speed/public-dns/ http://www.opendns.com/home-solutions/

For the record, I had tried changing my PC's DNS settings, but the router was over-riding my searches, so I had to change them there. It was very easy.