X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox seems to lpace frames around certain webpages that have no border color set... But in Firefox tehy appear.. but not in Explorer or Chrome. WHY? and hwo can we fix this in Mozilla?

已張貼

Why do borders appear around the frames on a site when the site has no border color set. It does not appear this way in Google Chrome or IE. It only does this with Firefox. How can this be corrected?

Why do borders appear around the frames on a site when the site has no border color set. It does not appear this way in Google Chrome or IE. It only does this with Firefox. How can this be corrected?

額外的系統細節

受影響的站台

http://www.ramacapital.com

已安裝的外掛程式

  • 3D Life Player Beta (4.1.0.78). For more information, visit the 3D Life Player web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • NPTURNMED
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Office Plugin for Netscape Navigator
  • Adobe PDF Plug-In For Firefox and Netscape
  • Shockwave Flash 10.1 r53
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • Google Update
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

應用程式

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.14) Gecko/2009082707 Firefox/3.0.14 (.NET CLR 3.5.30729)

更多資訊

Morbus 135 個解決方法 2340 個答案

Although possibly not related to your problem, I have to remind you that the version of Firefox you are using at the moment has been discontinued and is no longer supported. On top of this, it has known unpatched bugs and security problems. I urge you to update to the latest version of Firefox, for maximum security, stability, performance and usability. You can get it for free, as always, at getfirefox.com.

As for your issue, hopefully this support article is what you need:

http://support.mozilla.com/en-US/kb/Websites+look+wrong

Although possibly not related to your problem, I have to remind you that the version of Firefox you are using at the moment has been discontinued and is no longer supported. On top of this, it has known unpatched bugs and security problems. I urge you to update to the latest version of Firefox, for maximum security, stability, performance and usability. You can get it for free, as always, at [http://www.getfirefox.com getfirefox.com]. As for your issue, hopefully this support article is what you need: http://support.mozilla.com/en-US/kb/Websites+look+wrong
cor-el
  • Top 10 Contributor
  • Moderator
17573 個解決方法 158957 個答案

I'm not seeing any borders around the tables that have a border="0" set.
The main table has a border="1" and that is the only table with a border that I see.
Firefox 3.0.19 doesn't show a border either.


Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed the maximum file size (1 MB) and do not click Preview after you have attached the image.

I'm not seeing any borders around the tables that have a border="0" set.<br /> The main table has a border="1" and that is the only table with a border that I see.<br /> Firefox 3.0.19 doesn't show a border either.<br /> ---- Can you attach a [http://en.wikipedia.org/wiki/Screenshot screenshot]? Use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed the maximum file size (1 MB) and do not click Preview after you have attached the image.
engrafi 0 個解決方法 1 個答案

Actually I don't have the problem I thought I did.

What seems to be happening is that Firefox (3.6.9) (and every other browser I've checked – Camino 2.0.4, iCab 4, Netscape Navigator 7.2 & 9.0.0.6, Safari 5.0.2 and Shiira 2.2 – I don't have either Chrome or IE) are using the proper XHTML 1.0 specified behaviour, where the default is frameborder="1" for both frameset and frame.

I'm not sure when this excellent standards-compliance happened (at a guess, if NN7 did it, it would have been the case with Firefox 1.0?) but I never noticed the border in this page before. Now that I've added frameborder="0" attributes for both the frameset and enclosed frames, the border has disappeared.

(Hence, the answer to mts267 is presumably that this is how it's supposed to work unless frameborders are deliberately turned off. Which is a pain, but talk to W3C about that.)

I see the same behaviour still holds when using the ancient nonstandard "border" attribute in place of frameborder, too (which is what we used last time I actually wanted a frame border). Must be my eyesight. :-(

Incidentally, table borders are not the same as frame borders ... I'm talking about frame borders.

Actually I ''don't'' have the problem I thought I did. What seems to be happening is that Firefox (3.6.9) (and every other browser I've checked – Camino 2.0.4, iCab 4, Netscape Navigator 7.2 & 9.0.0.6, Safari 5.0.2 and Shiira 2.2 – I don't have either Chrome or IE) are using the proper XHTML 1.0 specified behaviour, where the default is frameborder="1" for both frameset and frame. I'm not sure when this excellent standards-compliance happened (at a guess, if NN7 did it, it would have been the case with Firefox 1.0?) but I never noticed the border in this page before. Now that I've added frameborder="0" attributes for both the frameset and enclosed frames, the border has disappeared. (Hence, the answer to mts267 is presumably that this is how it's supposed to work unless frameborders are deliberately turned off. Which is a pain, but talk to W3C about ''that''.) I see the same behaviour still holds when using the ancient nonstandard "border" attribute in place of frameborder, too (which is what we used last time I actually wanted a frame border). Must be my eyesight. :-( Incidentally, table borders are not the same as frame borders ... I'm talking about frame borders.