Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

I can't delete my location bar history

  • 5 回覆
  • 71 有這個問題
  • 57 次檢視
  • 最近回覆由 cor-el

more options

I'm on Firefox 3.6.8. I know that they're not bookmarks. I've of course highlighted them, and deleted with the DEL key, but when I type them in they come back. I deleted places.sqlite, I uninstalled Firefox and reinstalled. It was fine for a few minutes, but then the entire history came back. What can I do to get rid of it?

Oh, and switching it to only showing Bookmarks or Nothing doesn't seem to work

All Replies (5)

more options

try to delete it from the mozilla firefox folder

more options

See:



You need to update your plug-ins. It is important to keep them updated due to continuing security fixes and improvements in those plug-ins:

  • Macromedia Shockwave for Director Netscape plug-in, version 11.5 (you may need to update)
  • Adobe PDF Plug-In For Firefox and Netscape 9.3.3
  • Shockwave Flash 10.1 r53
  • Java Plug-in 1.6.0_20 for Netscape Navigator
  1. Check your plugin versions: http://www.mozilla.com/en-US/plugincheck/
    • Note: plugin check page does not have information on all plugin versions
  2. Update Shockwave for Director
    • NOTE: this is not the same as Shockwave Flash; this installs the Shockwave Player.
    • Use Firefox to download and SAVE the installer to your hard drive from the link in the article below (Desktop is a good place so you can find it).
    • When the download is complete, exit Firefox (File > Exit)
    • locate and double-click in the installer you just downloaded, let the install complete.
    • Restart Firefox and check your plugins again.
    • Download link and more information: http://support.mozilla.com/en-US/kb/Using+the+Shockwave+plugin+with+Firefox
  3. Update Adobe Reader (PDF plugin):
    • From within your existing Adobe Reader (if you have it already installed):
      • Open the Adobe Reader program from your Programs list
      • Click Help > Check for Updates
      • Follow the prompts for updating
      • If this method works for you, skip the "Download complete installer" section below and proceed to "After the installation" below
    • Download complete installer (if you do NOT have Adobe Reader installed):
      • Use Firefox to download and SAVE the installer to your hard drive from the link in the article below
      • On the Adobe page, un-check any extra items (i.e. Free McAfee® Security Scan Plus) then click Download button
      • If you see message just under tabs, DO NOT click the Allow button, instead click below that where it says "click here to download".
      • Click "Save to File"; save to your Desktop (so you can find it)
      • After download completes, close Firefox
      • Click the installer you just downloaded and allow the install to continue
        • Note: Vista and Win7 users may need to right-click the installer and choose "Run as Administrator"
      • Download link and more information: https://support.mozilla.com/en-US/kb/Using+the+Adobe+Reader+plugin+with+Firefox#Installing_and_updating_Adobe_Reader
    • After the installation, start Firefox and check your version again.
  4. Update Shockwave Flash
  5. Update Java:
more options

If you've used that profile in the past with Firefox 2 versions then you may have left a file history.dat that you need to delete as well.

See http://kb.mozillazine.org/History.dat and http://kb.mozillazine.org/Profile_folder_-_Firefox

more options

where is the folder where the firefox history is stored?

more options

Help > Troubleshooting Information > Profile Directory > Open Containing folder

See also Use the Troubleshooting Information page to help fix Firefox issues