搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

New windows don't open on top of each other in Firefox. How can I make that happen?

more options

New windows don't open on top of each other in Firefox. How can I make that happen? That is, every time I open a new window, it won't open on top of the old window, and instead is positioned to the right of it. I'm on a mac. Please help.

This happened

Every time Firefox opened

== Today

所有回覆 (4)

more options

There are a couple of different possible problems. Which do you mean?

1) When a new window opens, it opens in a tab instead of a new window 2) When a new tab opens, I want it to be the new current tab, but it opens in the background

How are you opening this window? You can right click on links and use "Open Link in New Window" to get a new window on top of the other.

more options

Thanks for the response.

I don't use tabs. Here's what the problem is:

When I open a new window, by either clicking on a link from my mail program, by going to the file menu and selecting, 'New Window,' or by clicking on Apple + N, a new browser window opens...BUT...

The new window doesn't open directly on top of the old window, but instead is positioned slightly to the right of the old window. I'd prefer to open windows right on top of each other. Is this possible? Thanks.

more options

I see. I'm not aware of how to fix this in Firefox. Usually you want to tweak your Winow Manager preferences for opening new windows.

Example: sawfish preferences for Linux.

Since Mac OS X doesn't have any preferences, you have to use Applescript or another technique. I found Spooky, maybe there are others. I haven't tried it, but here is the Spooky Download and Description.

more options

See if maximizing the Firefox window prevents that happening. Cascading windows is apparently standard on Mac if a window isn't maximized

See also https://bugzilla.mozilla.org/show_bug.cgi?id=421749 (please do not comment in bug reports)