搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't create Firefox internet shortcut while IE is default browser

  • 3 回覆
  • 46 有這個問題
  • 2912 次檢視
  • 最近回覆由 ptoulouk

more options

I want IE to be my default browser on my WinXP PC, but there are certain sites I prefer in Firefox, so want shortcuts for those on my desktop. But every time I drag the icon from firefox to the desktop, the shortcut changes to be for IE, and there doesn't seem to be anything I can change manually in properties to force the shortcut to open with Firefox.

This happened

Every time Firefox opened

== today

所有回覆 (3)

more options

Hi, I had the same problem.

When you create a shortcut on the desktop, paste the following before the web address that you are shortcutting:

“C:\Program Files\Mozilla Firefox\firefox.exe”

including the quotation marks. A shortcut to this page would read:

“C:\Program Files\Mozilla Firefox\firefox.exe” http://support.mozilla.com/en-US/forum/1/734824

more options

Thanks for the suggestion. I tried it and it won't save as you give it to me. Everytime I click "Apply" or "ok", my system appends "http" at the beginning and changes the slashes from backward to forward, so the URL ends up looking like: http://“C:/Program Files/Mozilla Firefox/firefox.exe”...

It may be that my problem is that I'm using an old browser (IE 6.0). I've tried upgrading to 7.0 but it freezes my system.

Let me know if you have other thoughts. Thanks, beth

more options

Delete the shortcut and create a new one. The shortcut you have now is expecting a internet address. If you create a new shortcut, it will act like a shortcut to firefox with the default page being your URL.