搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox 3.6.6 Renders the "Lucida Sans" font always in bold

more options

There seems to be a problem with Firefox rendering the "Lucida Sans" font. It doesn't seem to be able to find the regular or normal weight font and renders it instead in bold.

I am running Windows Server 2008 R2 (essentially Windows7).

I have tried reinstalling all of the Lucida Sans fonts in the font directory from another Windows Server 2008 R2 computer and that makes no difference in how the fonts are rendered.

If anyone could provide me with some help I would greatly appreciate it!

This happened

Every time Firefox opened

== I noticed it upgrading from Firefox 3.6.4 to 3.6.6

所有回覆 (12)

more options

I have upgraded to 3.6.8 since the problem started happening and there is still no changes.

Any ideas out there as to how I can fix this issue?

more options

i was having the same problem, but solved it by downloading lucida Sans font here and overwriting it. Hope it works for you.

more options

Not a great solution for web developers. Cant ask everyone to download a font to see a site correctly?

more options

This is still a problem in 3.6.10. C'mon.

I also tried downgrading to 3.5 and it didn't fix anything.

由 Khumpty 於 修改

more options

From my experience, this Lucida/Firefox font problem only happens to Adobe CS4 users. True for you?

more options

Nope, I have CS5 and a coworker has no CS anything installed. It happened right when the update to 3.6.10 occurred.

more options

I have noticed that CS4 seems to be the culprit as well. Me and another coworker with the CS4 suite installed both have the problem. I just had another coworker upgrade to FF 3.6.10, he has no CS products installed, and the problem does not exist.

more options

It looks bold for me too. I have FF 3.6.10, CS4 on Vista 64bit. IE and Chrome look fine. I have another PC with the same setup sans CS4 and Lucid Sans looks normal in FF.

more options

Upgraded to version 4.0.1 and it's STILL a problem.

I also use CS4 - but all other major browsers still display properly even so.

Even IE6 displays the font properly.

It's not just that it displays in bold it also looks very patchy too.

Is anybody going to fix this, or is the answer just a lazy "don't use that font"?

more options

Had the same problem with Firefox 4.0. I had previously installed Adobe CS4, now uninstalled and have CS5 instead. Fixed the problem by reinstalling the font. Google 'download lucida sans' and you can find the .ttf file easy enough. Here is the one I used: Lucida Sans Regular

由 spwestwood 於 修改

more options

Try Lucida Sans Unicode - it worked for me under Windows!

more options

I believe this is caused by an ambiguity in font names. "Lucida Sans" is the name of a family of fonts, not a single font. Therefore, when a website specifies "Lucida Sans" the browser/OS will pick one of the fonts within the family. If the PC has Lucida Sans Regular, it will typically pick that. If it doesn't, it may pick one of the others in the family, e.g. bold or italic. A common cause of this seems to be the situation I had: Windows XP - shipped with Lucida Sans Regular. Windows 7 - no longer ships with Lucida Sans Regular Office 2007 - still ships with the additional Lucida Sans styles (italic, bold)

Therefore if you install Office 2007 on Windows 7, you will have the variations of Lucida Sans, but not the original Lucida Sans Regular. Under this situation, I had IE8 picking Lucida Sans Italic, though firefox somehow was picking something else. Perhaps Firefox got more robust recently?