搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Proposed solution for plugin-container.exe issue

more options

I understand there's a workaround for disabling plugin-container.exe via about:config, but in order to avoid any risky procedures:

Why not simply program a simple checkbox under tools/options to enable/disable this feature?

That way everyone is happy!! :-) and problem solved!

所有回覆 (17)

more options

Your Flash plugin is outdate. Please update using the Plugin Check if possible: http://www.mozilla.com/en-US/plugincheck/

If you're having issues with 3.6.4 and the Flash plugin, please take a look at Adobe Flash plugin has crashed - Prevent it from happening again and increase the timeout as indicated.

more options

Yeah disable this thing.. its hogging more ram than firefox lol well not realy

firefox 80,000k around that container 54,000k around that

Please make something that lets disable container..

more options

Firefox = 68k Plugin Container = 843k

WTF? It's slowing down my entire computer!

more options

Please fix the problem asap! It slows down my entire pc...

more options

the plugin container freezes my pc. i want it out

more options

This is slowing mine down as well, please get it fixed!!

more options

FIX THIS PROBLEM MOZILLA. I will not reprogram my computer and void my warranty to fix your defective product. THIS IS RIDICULOUS.

more options

See this for information about how to disable the plugin container. http://forums.mozillazine.org/viewtopic.php?p=9530495#p9530495

more options

The solution in the forum topic that was linked above is not completely accurate (the first dom.ipc.plugins.enabled preference should remain set to "false". Only the four dom.ipc.plugins.enabled. preferences should be toggled from "true" to "false").

Here is a new MozillaZine KB article with detailed information about plugin-container and how to disable it:

http://kb.mozillazine.org/Plugin-container_and_out-of-process_plugins#Disabling_crash_protection

more options

Why not just fix it instead?

more options

If your issue is Flash plugin crashes, hangs, high CPU pr other problems viewing Flash videos on certain sites, try disabling hardware acceleration in your Flash settings. (Right-click on any Flash video, click "Settings", select the Display tab and uncheck “Enable hardware acceleration".) Ref: http://kb.mozillazine.org/Flash#Performance_or_display_issues_with_certain_Flash_videos

If you see performance or display issues with certain Flash videos (e.g., high CPU usage, hangs, white or green screen, no full-screen video, distortion) turn off hardware acceleration in your Flash Player display settings (Right-click on any Flash video, click "Settings", select the Display tab and uncheck “Enable hardware acceleration"). Note: Flash 10.1 uses enhanced hardware acceleration (H.264 video hardware decoding) on systems with supported video cards and drivers running Windows XP, Windows Vista, and Windows 7. For details, read Flash Player 10.1 hardware acceleration for video and graphics.

Related bug report: Bug 575326 - Flash plugin crash @ nvapi.dll@0x4683e @ nvapi.dll@0x4e97e on Flash videos with certain nvidia graphics drivers

more options

I had the same problem with plugin-container slowing down my computer. I was only trying to read my email in my Hotmail account. No plugins were in use.

Why does plugin-container run when there are no plugins in use?

Using: Ubuntu 9.10, Firefox 3.6.8

more options

John,

A plugin-container process will be started and remain running for each "IPC-enabled" ('OOPP") plugin that is used during the Firefox session, even if you leave all sites that use that plugin. In other words, if you go to any site that uses the Flash plugin, a plugin-container will be started for Flash and it will continue running until you exit Firefox.

If you have problems with plugin-container, you can disable it as explained HERE. As a workaround, exit Firefox completely and then start a new Firefox session before accessing your Hotmail account.

more options

Time to try another browser. Firefox is becoming like IE.

more options

I'm using Firefox under Win XP. I found plugin-container.exe was taking up to 99% of my CPU. So I did the following.... From Firefox, tools, add-ons, click plugins, scroll down to shockwave flash, click disable. Everything now runs much better. If I browse to a page where I have to use it, then I can enable it. But so far I've not had a use for it. Seems mainly to be used for adverts!

more options

I have been wrestling with stuttering video and occasional flat out crashes since upgrading to FireFox 4 as soon as it came out. This peaked over the past 10 days, as I have been forced due to breaking an ankle to work with my laptop via wireless. I listen to YouTube playlists in the background. The constant stuttering, stopping, stalling, and restarting has been virtually unbearable, and I am using my Netgear highspeed wireless router and getting 270 Mbps on the laptop, for Pete's sake. I could not even watch videos and entertain myself.

Finally, because of the stalling, I looked in Task Manager (Win XP on this laptop, problems on Win 7 desktop, too, FWIW), and there was the plugin-container.exe eating an average 25% of CPU!!!!

I found numerous references on how to disable this crap, e.g. http://kb.mozillazine.org/Plugin-container_and_out-of-process_plugins#Disabling_crash_protection.

I just did it. I restarted FireFox. I am now a half dozen videos deep into a Vangellis playlist on YouTube, and it HAS NOT STUTTERED OR STALLED ONCE.

Not ONCE, and it has done NOTHING but stall for the past 10 days, every day, for hours at a time.

If there were ever a more convincing test of cause and effect, I do not know what it is.

What I do know is that the effort to isolate with plugin-container.exe in FireFox is a total, unmitigated disaster, and the developers need to be reading and paying attention to these threads.

Again, 10 days sitting here and nothing but stuttering and stalling. Change 4-5 lines in about:config, shut this piece off, and I am now almost 15 minutes into a playlist and NOT ONE SINGLE STALL OR STUTTER.

And of course the massive CPU consumption was hitting other stuff while browsing the web or working.

more options

This is followup to my post a couple days ago.

Despite the immediate success I had watching movie videos on YouTube setting values to false for entries in FireFox config affecting plugin-container.exe, I am still experiencing problems with other videos, and occasionally even with the music videos I was watching.

So this was not a complete solution, apparently.

I wish I knew what the answer was. There does not seem to be a non-hidef versus hidef issue. Videos will still just stall and stutter.

Still looking for full solution to this, if anyone at mozilla or FireFox team has a clue.