X
點擊此處開啟此網站的行動版。

技術支援討論區

The search bar is not visible.

已張貼

The search bar is just plain not there. I have deinstalled, deleted the old Mozilla folder and re-installed/upgraded with the same result. When I start FF in safe mode, the search bar is there. Clearing prefs, returning to defaults have no effect.

This happened

Every time Firefox opened

== As long as I've been here

The search bar is just plain not there. I have deinstalled, deleted the old Mozilla folder and re-installed/upgraded with the same result. When I start FF in safe mode, the search bar is there. Clearing prefs, returning to defaults have no effect. == This happened == Every time Firefox opened == As long as I've been here

額外的系統細節

已安裝的外掛程式

  • -DBsign Web Signer Plugin
  • JInitiator 1.3.1.26 for Netscape Navigator (DLL Helper)
  • VBrick (tm) Video Player Plugin
  • Adobe PDF Plug-In For Firefox and Netscape
  • Default Plug-in
  • Shockwave Flash 10.0 r45
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

應用程式

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 (.NET CLR 3.5.30729)

更多資訊

Firefox 3.5.4 Windows XP SP3

TXGuy 87 個解決方法 861 個答案

"When I start FF in safe mode, the search bar is there."

If the problem does not occur in Safe-mode then disable all of your Extensions and Plug-ins and then try to find which is causing it by enabling one at a time until the problem reappears. You MUST close and restart Firefox after EACH change via File > Restart Firefox (on Mac: Firefox > Quit). You can use "Disable all add-ons" on the Safe mode start window.

See: Troubleshoot Firefox issues using Safe Mode Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems Troubleshoot and diagnose Firefox problems

'''''"When I start FF in safe mode, the search bar is there."''''' If the problem does not occur in Safe-mode then disable all of your Extensions and Plug-ins and then try to find which is causing it by enabling <u>'''one at a time'''</u> until the problem reappears. <u>'''You MUST close and restart Firefox after EACH change'''</u> via File > Restart Firefox (on Mac: Firefox > Quit). You can use "Disable all add-ons" on the Safe mode start window. See: '''[[Safe Mode]]''' '''[[Troubleshooting extensions and themes]]''' '''[[Troubleshooting plugins]]''' '''[[Basic Troubleshooting]]'''

提出問題者

Done, No avail. Disabling all extensions has no effect. The search bar still is not visible.

Done, No avail. Disabling all extensions has no effect. The search bar still is not visible.
cor-el
  • Top 10 Contributor
  • Moderator
17415 個解決方法 157328 個答案

有幫助的回覆

* If on Windows in Firefox 3.6 the menu bar is hidden then press and hold the Alt key down, that should make the "Menu Bar" appear.
* Go to "View > Toolbars" and put a check-mark for "Menu Bar" to make that permanent. See Restore the Menu bar in Firefox).
* Make sure that you have the Navigation Toolbar and other toolbars visible: "View > Toolbars"
* If items are missing then see if you can find them in the "View > Toolbars > Customize" window.
* If you see the item in the Customize window then drag it back from the Customize window to the Navigation toolbar.
* If you do not see that item then click the "Restore Default Set" button in the "View > Toolbars > Customize" window.

See also: http://kb.mozillazine.org/Toolbar_customization http://kb.mozillazine.org/Corrupt_localstore.rdf

* If on Windows in Firefox 3.6 the menu bar is hidden then press and hold the Alt key down, that should make the "Menu Bar" appear. * Go to "View > Toolbars" and put a check-mark for "Menu Bar" to make that permanent. See [[Menu bar is missing]]). * Make sure that you have the ''Navigation Toolbar'' and other toolbars visible: "View > Toolbars" * If items are missing then see if you can find them in the "View > Toolbars > Customize" window. * If you see the item in the Customize window then drag it back from the Customize window to the Navigation toolbar. * If you do not see that item then click the "Restore Default Set" button in the "View > Toolbars > Customize" window. See also: http://kb.mozillazine.org/Toolbar_customization http://kb.mozillazine.org/Corrupt_localstore.rdf

提出問題者

No. None of this worked. Already tried.

I have tried returning to original settings. I have disabled all extensions. Still no search bar. I've also completely de-installed the app, and removed existing program files folder.

When FF runs in safe mode, the search bar is there. Whenever I start FF normally, there is no search bar.

Please Help!

No. None of this worked. Already tried. I have tried returning to original settings. I have disabled all extensions. Still no search bar. I've also completely de-installed the app, and removed existing program files folder. When FF runs in safe mode, the search bar is there. Whenever I start FF normally, there is no search bar. Please Help!
cor-el
  • Top 10 Contributor
  • Moderator
17415 個解決方法 157328 個答案

Did you try to delete the file localstore.rdf in the Firefox Profile Folder ?

See http://kb.mozillazine.org/Corrupt_localstore.rdf (caution: do not delete the localstore.rdf file in the Firefox program installation folder)

Note: Deleting the file localstore.rdf will reset the customizations of the toolbars to the defaults. You can rename localstore.rdf to localstore.rdf.sav to test if that solves it. Then you can restore the customization by copying localstore.rdf.sav to localstore.rdf if it didn't work.

Did you try to delete the file localstore.rdf in the [http://kb.mozillazine.org/Profile_folder_-_Firefox Firefox Profile Folder] ? See http://kb.mozillazine.org/Corrupt_localstore.rdf (caution: do not delete the localstore.rdf file in the Firefox program installation folder) Note: Deleting the file [http://kb.mozillazine.org/localstore.rdf localstore.rdf] will reset the customizations of the toolbars to the defaults. You can rename ''localstore.rdf'' to '''localstore.rdf.sav''' to test if that solves it. Then you can restore the customization by copying ''localstore.rdf.sav'' to ''localstore.rdf'' if it didn't work.