搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Location Bar autocomplete and drop-down menu (a browser.urlbar setting conflict)

  • 無回覆
  • 0 有這個問題
  • 12 次檢視
more options

I would like to completely turn off Location Bar auto-complete but retain use of the Location Bar drop-down menu (which displays when you click the small arrow adjacent to the URL). These appear to be mutually exclusive as a security feature.

Setting urlbar.autocomplete.enable to false (or setting Tools>Options>Privacy Tab>Location Bar to Nothing) eliminates access to the drop-down menu.

I use OldBar because I'm a minimalist. My end goal is a Location Bar that only stores URL's I hand enter (achieved by setting urlbar.default.behavior to "32"), has autocomplete turned off, and a functional drop-down.

I'm not a programmer, but as a suggested fix: change autocomplete.enable to an integer as follows: 0 = autocomplete off, and shuts off other Location Bar functionality (currently "false") 1 = autocomplete off, and leaves on other Location Bar functionality 2 = autocomplete on (currently "true")

Thanks for the help.

I would like to completely turn off Location Bar auto-complete but retain use of the Location Bar drop-down menu (which displays when you click the small arrow adjacent to the URL). These appear to be mutually exclusive as a security feature. Setting urlbar.autocomplete.enable to false (or setting Tools>Options>Privacy Tab>Location Bar to Nothing) eliminates access to the drop-down menu. I use OldBar because I'm a minimalist. My end goal is a Location Bar that only stores URL's I hand enter (achieved by setting urlbar.default.behavior to "32"), has autocomplete turned off, and a functional drop-down. I'm not a programmer, but as a suggested fix: change autocomplete.enable to an integer as follows: 0 = autocomplete off, and shuts off other Location Bar functionality (currently "false") 1 = autocomplete off, and leaves on other Location Bar functionality 2 = autocomplete on (currently "true") Thanks for the help.