搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox user agent has an empty parentheses "( )" at the end

  • 3 回覆
  • 2 有這個問題
  • 39 次檢視
  • 最近回覆由 Chris Ilias

more options

We've noticed that some users hitting our website have an empty ( ) at the end of their user agent string. This is typically where the .net framework asst version info is. We only see it with the latest generation of firefox, 3.6.3, 3.5.9, etc. It seems to have started or gotten much worse around 4/26. Here is an example - "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( )" Anyone have any idea what changed? - Thanks

== roughly 4/26

所有回覆 (3)

more options

Go to about:config. In the filter field, type agent. You should get a list of preferences that have agent in the name. Right-click on any bold ones, and select Reset.

more options

That's not going to do him any good, the problem is with visitors to his website and the UA log file on the server.

Kendall, I have no idea why that would happen. AFAIK nothing was changed in Firefox recently to cause that, and we don't see that ( ) happening in the UserAgent strings that are displayed here at the start of each thread. Plus, I don't see that happening at the MozillaZine fora which displays the UA for every posting made there.

more options

oops - didn't mean to post anonymously

the-edmeister is correct - thank you. The problem is not with my browser, but with some of our users. I'm still searching for the root cause here. We're coding around it but I hate not knowing. I reinstalled Firefox 3.6.3 today on XP and noticed that the microsoft .net framework assistant is disabled. I have an older install of 3.5.9 on windows 7 and on that version I can choose to disable it. This leads me to believe that there are some changes or development going on around this add-on that could account for our problem. I just need to find someone who knows the Firefox code that handles the user agent.