搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox Screenshot Title Issue

  • 8 回覆
  • 3 有這個問題
  • 1 次檢視
  • 最近回覆由 nyanmogus

more options

When I used to take screenshots, they would be automatically named with the date, time, and part of the text captured regardless of language. A few days ago and with no reason I can discern, it now saves any non-English screenshots with something like this "Screenshot 2024-06-23 a[...].png" instead of "Screenshot 2024-06-22 at 08-02-28 Politics Policy Polit[...].png" (usual for English text and what I used to get with all languages).

Which means I have to manually rename screenshots. Does anyone know how I can fix this because I am working on a project with lots of screenshots for topics from different languages?

When I used to take screenshots, they would be automatically named with the date, time, and part of the text captured regardless of language. A few days ago and with no reason I can discern, it now saves any non-English screenshots with something like this "Screenshot 2024-06-23 a[...].png" instead of "Screenshot 2024-06-22 at 08-02-28 Politics Policy Polit[...].png" (usual for English text and what I used to get with all languages). Which means I have to manually rename screenshots. Does anyone know how I can fix this because I am working on a project with lots of screenshots for topics from different languages?

由 NoahSUMO 於 修改

被選擇的解決方法

You can set screenshots.browser.component.enabled to false in about:config to revert to the old behavior.

從原來的回覆中察看解決方案 👍 4

所有回覆 (8)

more options

有幫助嗎?

more options

Agent virtuel said

Hello Taking screenshots https://firefox-source-docs.mozilla.org/devtools-user/taking_screenshots/index.html can be useful to you ? for illustration purposes https://www.youtube.com/embed/XE1MpIMi594 - https://www.youtube.com/embed/optjk7BPOu0

That is the function I am already using which has the issue.

有幫助嗎?

more options

FF 126 worked as expected, giving a "save" filename as "screenshot----time-----FULL details ect" .png

127 update broke this to give only partial details, ending in [.....] and the "download" box now pops up at the top of the screen.

How to revert to original behaviour as I use screenshot extensively in copying genealogy site information to my computer.

有幫助嗎?

more options

Firefox 127 enabled a new screenshot component (controlled by screenshots.browser.component.enabled). This includes shortening long page titles to prevent issues with saving the screenshot to a deeply nested folder structure that exceeds the OS maximum.

See Changed:

有幫助嗎?

more options

cor-el said

Firefox 127 enabled a new screenshot component (controlled by screenshots.browser.component.enabled). This includes shortening long page titles to prevent issues with saving the screenshot to a deeply nested folder structure that exceeds the OS maximum. See Changed:

I see that. However, I am looking for a way to fix it so it can go back to the way it used to.

有幫助嗎?

more options

選擇的解決方法

You can set screenshots.browser.component.enabled to false in about:config to revert to the old behavior.

有幫助嗎?

more options

Sir, you are a genius - problem solved. Firefox now back up to date and screenshot titles saving as they used to. Thank you very much, Glenn

由 Glenn Heaton 於 修改

有幫助嗎?

more options

cor-el said

You can set screenshots.browser.component.enabled to false in about:config to revert to the old behavior.

Just a warning - this workaround seems to disable all of the new screenshot features (like taking screenshots of about: pages or SVGs), not just the filename change

由 nyanmogus 於 修改

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題