搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How to disable Private Browsing Mode with Firefox Flatpak version

  • 4 回覆
  • 1 有這個問題
  • 1 次檢視
  • 最近回覆由 TGM

more options

I'm trying to get my Firefox installation to permanently disable private browsing mode, however, all information I can find is for the Snap version of Firefox, and not for the Flatpak version. How do I disable private browsing on my installation?

I'm trying to get my Firefox installation to permanently disable private browsing mode, however, all information I can find is for the Snap version of Firefox, and not for the Flatpak version. How do I disable private browsing on my installation?

被選擇的解決方法

Looks good to me assuming that that is the correct Firefox installation folder. You can check this in about:support under "Application Basics -> Application Binary".

You can open the about:policies page to see if policies are active and if errors are reported.

從原來的回覆中察看解決方案 👍 0

所有回覆 (4)

more options

The only way to disable PB mode is via a policies.json, I assume that this works the same on Flatpak and Snap.

有幫助嗎?

more options

Ive tried that, but no dice. I the put policies.json file in /usr/lib/firefox/distribution, and this is in the file: {

 "policies": {
   "DisablePrivateBrowsing": true
 }

}


Is there anything I did wrong?

有幫助嗎?

more options

選擇的解決方法

Looks good to me assuming that that is the correct Firefox installation folder. You can check this in about:support under "Application Basics -> Application Binary".

You can open the about:policies page to see if policies are active and if errors are reported.

有幫助嗎?

more options

Thank you! It wasn't under /usr/lib/firefox/distribution, and instead under /app/lib/firefox/firefox-bin

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題