搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox 127 - close tab button missing for background tabs when more than 10 tabs opened

  • 2 回覆
  • 1 有這個問題
  • 1 次檢視
  • 最近回覆由 Piterk

more options

In previous versions I was able to open around 15-20 tabs before X button disappeared from them and I was no longer able to close them without activating them first.

Now this happens much earlier - only 10 tabs is enough on my 1080p 100% scaling desktop and 9 tabs on my 1080p 125% notebook.

X button is present if you have 10 tabs or less, but disappears with 11 tabs, when there is still plenty of space on tabs to click on X!

I compared it to brave and in brave you can still have 22 tabs opened before X button disappears!

Anyone has any method to force presence of x button? This is really annoying as I often have much tabs open and close only 2-3 of them. Now I have to open each one again to be able to close it.

In previous versions I was able to open around 15-20 tabs before X button disappeared from them and I was no longer able to close them without activating them first. Now this happens much earlier - only 10 tabs is enough on my 1080p 100% scaling desktop and 9 tabs on my 1080p 125% notebook. X button is present if you have 10 tabs or less, but disappears with 11 tabs, when there is still plenty of space on tabs to click on X! I compared it to brave and in brave you can still have 22 tabs opened before X button disappears! Anyone has any method to force presence of x button? This is really annoying as I often have much tabs open and close only 2-3 of them. Now I have to open each one again to be able to close it.
附加的畫面擷圖

所有回覆 (2)

more options

選擇的解決方法

由 Agent virtuel 於 修改

有幫助嗎?

more options

Thank you! This resolved my issue! Shame that they introduce background changes in ui again and do not notify about it in changelogs, but I already got used to every FF update breaking something.

P.S. Someone on reddit recommended even better code: .tab-close-button { &[pinned], #tabbrowser-tabs[closebuttons="activetab"] > #tabbrowser-arrowscrollbox > .tabbrowser-tab:hover > .tab-stack > .tab-content > &:not([selected]) { display: unset !important;} }

If you do not want X on pinned tabs just remove " &[pinned], " part.

由 Piterk 於 修改

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題