搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

ClassicPress password reset links not working when clicking links from mail using Firefox Dev edition

more options

Hi,

I use ClassicPress (fork of WordPress) and I have a problem when requesting a password reset link for it.

When opening the email received to reset password in the firefox dev edition browser and click the reset link I receive an error stating that the link is invalid.

I discovered by trial and error that copying the same link and pasting it manually in a new tab of the same firefox dev edition browser solves the issue because then the link is recognised as valid.

This happened after the update I received last week.

I am a linux mint user if that helps in tracking down the issue.

Hi, I use ClassicPress (fork of WordPress) and I have a problem when requesting a password reset link for it. When opening the email received to reset password in the firefox dev edition browser and click the reset link I receive an error stating that the link is invalid. I discovered by trial and error that copying the same link and pasting it manually in a new tab of the same firefox dev edition browser solves the issue because then the link is recognised as valid. This happened after the update I received last week. I am a linux mint user if that helps in tracking down the issue.
附加的畫面擷圖

所有回覆 (1)

more options

Hmm, what is the difference between clicking a link and copy/pasting it?

This is a little hard to investigate because links in email messages usually open in a new tab, so the normal Network Monitor loses track of the request and it's tricky to see the exact difference between the clicked link and the pasted link. You could try using the Browser Console (Ctrl+Shift+J). Change to Multiprocess, click the gear/wheel button and turn on Enable Network Monitoring, click the Requests filter to turn it on, then finally click the trash can. Now keep this open while you launch the link from the email and compare with what you expected.

Does it look like some security service or add-on (or beta feature?) is removing the key because it looks like a tracking parameter?

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題