搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

captcha does nothing but spin the circle when trying to log into Disqus

  • 4 回覆
  • 1 有這個問題
  • 1 次檢視
  • 最近回覆由 miklkit

more options

I use Disqus daily. A few months ago it became necessary to disable the shield in the address line. Yesterday captcha quit working. I input my email and password and click captcha and the circle starts spinning and never ends. This happens on all sites using Disqus.

 Is there any way to get Firefox to work with Disqus and Captcha?
I use Disqus daily. A few months ago it became necessary to disable the shield in the address line. Yesterday captcha quit working. I input my email and password and click captcha and the circle starts spinning and never ends. This happens on all sites using Disqus. Is there any way to get Firefox to work with Disqus and Captcha?

由 miklkit 於 修改

被選擇的解決方法

This should have been fixed by Google.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings), click the padlock icon (Clear cookies and site data) for the domain in the selected tab.

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can check for issues with Enhanced Tracking Protection. Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages like blocked content.

從原來的回覆中察看解決方案 👍 1

所有回覆 (4)

more options

Only Firefox with a Windows user agent seems to be affected by this issue with reCAPTCHA not working. It works for me with a MAC user agent and with a Linux user agent. You can use a User-Agent Switcher extension and set the user agent to Chrome or Edge on Windows 11.

This has been reported to Google, so wait until Google fixes this and then undo this temporary fix.

有幫助嗎?

more options

I found and installed that extension last night. Nothing changed. Supposedly when activated its icon appears in the toolbar. Well, it does not. I deleted it last night.

 This morning I read your reply and tried again.  Same result.  Nothing.  I have no way to use that extension, so can do nothing.  I have watched 2 videos and they show an icon in the upper right hand corner that gets the extension working.  I do not have that icon.  
 I am still locked out of all sites that use captcha.

有幫助嗎?

more options

選擇的解決方法

This should have been fixed by Google.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings), click the padlock icon (Clear cookies and site data) for the domain in the selected tab.

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can check for issues with Enhanced Tracking Protection. Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages like blocked content.

有幫助嗎?

more options

I replied first thing this morning, then tried Firefox again and today captcha is working again. Thank you for the replies.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題