搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Pages intermittently but frequently not loading, spinning wheel, 2-3 second delay if you CTRL-W that tab

  • 7 回覆
  • 0 有這個問題
  • 4 次檢視
  • 最近回覆由 Luckspeare

more options

Hi all. I've been experiencing over the past months an increasingly frequent problem where trying to load a web page shows a spinning wheel for as little as 3 minutes but sometimes until you finally lose patience and close it. When this occurs, closing this tab has a 2-3-second delay.

After the problem ceases temporarily, I will be able to load the same page a few times afterward without problem, and it will work for some time until it happens again. I can see no rhyme or reason to it. When it occurs, no pages of any sort will open; I have to use another browser to try to find solutions. When the current recurrence of the problem stops, all pages that were stuck with spinning wheels now resume loading again at the same time. It's like something is breaking internally then resuming some 3-20 minutes later.

This does not occur on any of 3 other browsers (Vivaldi, Yandex, Opera) that I have tried. I have never run into this issue until it started several months ago.

I have gone through the steps shown in the help document for pages not loading on Firefox but loading in other browsers. I have turned off the indicated settings (IPv6, forced HTTPS, no proxy, use only my ISP's DNS, etc.), removed all extensions, and completely reset my profile to defaults.

Just don't know what else to do here. It feels like it's got to be a bug. I do know that I have recently in the last months split into running separate work and personal profiles. It's affecting both profiles, and one of them was created at that time. So also wondering if it could be a problem with having separate Firefox threads/processes running and causing problems with each other, since I constantly have both profiles up separately.

Hi all. I've been experiencing over the past months an increasingly frequent problem where trying to load a web page shows a spinning wheel for as little as 3 minutes but sometimes until you finally lose patience and close it. When this occurs, closing this tab has a 2-3-second delay. After the problem ceases temporarily, I will be able to load the same page a few times afterward without problem, and it will work for some time until it happens again. I can see no rhyme or reason to it. When it occurs, no pages of any sort will open; I have to use another browser to try to find solutions. When the current recurrence of the problem stops, all pages that were stuck with spinning wheels now resume loading again at the same time. It's like something is breaking internally then resuming some 3-20 minutes later. This does not occur on any of 3 other browsers (Vivaldi, Yandex, Opera) that I have tried. I have never run into this issue until it started several months ago. I have gone through the steps shown in the help document for pages not loading on Firefox but loading in other browsers. I have turned off the indicated settings (IPv6, forced HTTPS, no proxy, use only my ISP's DNS, etc.), removed all extensions, and completely reset my profile to defaults. Just don't know what else to do here. It feels like it's got to be a bug. I do know that I have recently in the last months split into running separate work and personal profiles. It's affecting both profiles, and one of them was created at that time. So also wondering if it could be a problem with having separate Firefox threads/processes running and causing problems with each other, since I constantly have both profiles up separately.

所有回覆 (7)

more options

... Yeah, I think it did start about the same time that I started working in separate Firefox profiles in separate processes.

有幫助嗎?

more options

If you use Sync, best is to disconnect Sync temporarily during troubleshooting.

This could be a problem with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use the "Places Database" -> "Verify Integrity" button on the "Help -> More Troubleshooting Information" (about:support) page

If errors are reported with "Verify Integrity", close and restart Firefox or reboot and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder with Firefox closed. Firefox will rebuild places.sqlite and restore the bookmarks from the most recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created
  • you lose the history when a new places.sqlite is created

You may have to restore an older bookmarks backup in the bookmarkbackups folder via the Bookmarks Manager (Library).

See also:

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

有幫助嗎?

more options

Thanks Cor-El. I verified integrity on the places database and it produced this output, which seems like there were no errors:

> Task: checkIntegrity + The places.sqlite database is sane + The favicons.sqlite database is sane > Task: checkCoherence + The database is coherent > Task: expire + Database cleaned up > Task: vacuum + Initial database size is 5120KiB + The database has been vacuumed + Final database size is 5120KiB > Task: stats + Places.sqlite size is 5120KiB + Favicons.sqlite size is 5120KiB + pragma_user_version is 75 + pragma_page_size is 32768 + pragma_cache_size is -2048 + pragma_journal_mode is wal + pragma_synchronous is 1 + History can store a maximum of 64199 unique pages + Table moz_origins has 154 records + Table moz_places has 2339 records + Table moz_places_extra has 0 records + Table moz_historyvisits has 3057 records + Table moz_historyvisits_extra has 0 records + Table moz_inputhistory has 0 records + Table moz_bookmarks has 13 records + Table moz_bookmarks_deleted has 0 records + Table moz_keywords has 0 records + Table sqlite_sequence has 1 records + Table moz_anno_attributes has 2 records + Table moz_annos has 1212 records + Table moz_items_annos has 0 records + Table moz_meta has 7 records + Table moz_places_metadata has 1391 records + Table moz_places_metadata_search_queries has 0 records + Table moz_previews_tombstones has 0 records + Table sqlite_stat1 has 19 records + Pages sequentiality: 70.2 + sqlite_schema: 32KiB (1.2%), 24.6% eff. + moz_origins: 32KiB (1.2%), 17.9% eff. + sqlite_autoindex_moz_origins_1: 32KiB (1.2%), 15.3% eff. + moz_places_extra: 32KiB (1.2%), 0% eff. + moz_historyvisits_extra: 32KiB (1.2%), 0% eff. + moz_inputhistory: 32KiB (1.2%), 0% eff. + sqlite_autoindex_moz_inputhistory_1: 32KiB (1.2%), 0% eff. + moz_bookmarks: 32KiB (1.2%), 2.3% eff. + moz_bookmarks_deleted: 32KiB (1.2%), 0% eff. + sqlite_autoindex_moz_bookmarks_deleted_1: 32KiB (1.2%), 0% eff. + moz_keywords: 32KiB (1.2%), 0% eff. + sqlite_autoindex_moz_keywords_1: 32KiB (1.2%), 0% eff. + sqlite_sequence: 32KiB (1.2%), 0.1% eff. + moz_anno_attributes: 32KiB (1.2%), 0.2% eff. + sqlite_autoindex_moz_anno_attributes_1: 32KiB (1.2%), 0.2% eff. + moz_items_annos: 32KiB (1.2%), 0% eff. + moz_meta: 32KiB (1.2%), 0.8% eff. + moz_places_metadata_search_queries: 32KiB (1.2%), 0% eff. + sqlite_autoindex_moz_places_metadata_search_queries_1: 32KiB (1.2%), 0% eff. + moz_previews_tombstones: 32KiB (1.2%), 0% eff. + sqlite_stat1: 32KiB (1.2%), 3.2% eff. + moz_places_url_hashindex: 32KiB (1.2%), 99.6% eff. + moz_places_visitcount: 32KiB (1.2%), 57.8% eff. + moz_places_frecencyindex: 32KiB (1.2%), 64.8% eff. + moz_places_originidindex: 32KiB (1.2%), 63.9% eff. + moz_places_altfrecencyindex: 32KiB (1.2%), 56.7% eff. + moz_historyvisits_fromindex: 32KiB (1.2%), 89% eff. + moz_bookmarks_itemindex: 32KiB (1.2%), 0.4% eff. + moz_bookmarks_parentindex: 32KiB (1.2%), 0.4% eff. + moz_bookmarks_itemlastmodifiedindex: 32KiB (1.2%), 0.7% eff. + moz_bookmarks_dateaddedindex: 32KiB (1.2%), 0.6% eff. + moz_bookmarks_guid_uniqueindex: 32KiB (1.2%), 0.8% eff. + moz_keywords_placepostdata_uniqueindex: 32KiB (1.2%), 0% eff. + moz_annos_placeattributeindex: 32KiB (1.2%), 42% eff. + moz_items_annos_itemattributeindex: 32KiB (1.2%), 0% eff. + moz_places_metadata_placecreated_uniqueindex: 32KiB (1.2%), 71.5% eff. + moz_places_metadata_referrerindex: 32KiB (1.2%), 36.5% eff. + moz_places_metadata: 96KiB (3.5%), 53.9% eff. + moz_places_hostindex: 96KiB (3.5%), 65.2% eff. + moz_places_lastvisitdateindex: 96KiB (3.5%), 37.9% eff. + moz_places_guid_uniqueindex: 96KiB (3.5%), 47.5% eff. + moz_historyvisits_placedateindex: 96KiB (3.5%), 58.8% eff. + moz_historyvisits_dateindex: 96KiB (3.5%), 49.7% eff. + moz_historyvisits: 128KiB (4.7%), 59.9% eff. + moz_annos: 192KiB (7.1%), 67.3% eff. + moz_places: 640KiB (23.5%), 93% eff. > Task: _refreshUI

No luck yet it seems.

有幫助嗎?

more options

I see right now that Firefox goes completely incommunicado. Nothing works -- something is hung internally it seems. When this occurs, the Spotify page currently open and playing music ceases up until the stoppage has completed.

有幫助嗎?

more options

Okay, I think I am closer to figuring out what it is. May be an extension thing, but it did this when I had extensions disabled too, I'm pretty sure??

So I'm watching Process Manager, and I see Extensions is around 0% CPU usage. Jumps up to 33%, then 97% then 110%. Within about 5-10 seconds of it jumping past 100%, everything ceases up, including the music again. (See attached image.)

Actual CPU usage of Firefox (as measured in Process Explorer at OS level) is minimal and hardly increases.

I've reinstalled latest JRE and re-disabled all extensions to make sure.

有幫助嗎?

more options

Reinstall the Visual C++ Redistributable.

Disable any third-party antivirus or security software, this may require rebooting into Windows Safe Mode (networking enabled).

Disable third-party modules in about:third-party.

有幫助嗎?

more options

Thanks, Zeroknight. I've done that and am pending reboot because reboot is normally something that's done bi-annually for me (only partially kidding), but I'll report back afterward.

It would so far seem, though, that it's Adblocker Ultimate doing it. I'm really sorry guys, I really thought I had that disabled when I first reported, but I guess it wasn't. Not 100% sure, but it sure looks like the culprit so far.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題