搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Problems with Google on Firefox

more options

On my laptop (121.0 on doze 10) I have no problems but on my desktop Firefox (121.0 on doze 10) started to struggle with Google a few months ago. Sometimes the Google site doesn't load, sometimes it loads but doesn't connect (no auto-complete, no search) and if it does work the result links often don't load when clicked. It's like Google falls asleep and then, when it wakes up, all is fine, until it nods off again. I have followed advice provided, cleared cache, cleared cookies, removed plugins and extensions, reinitiated and reinstalled. Running in safe mode seems to help, as in pages seem to load faster, but sadly does not eliminate the problems. Other browsers on this machine are not affected. No time sync issues.

Any suggestions?

TIA

On my laptop (121.0 on doze 10) I have no problems but on my desktop Firefox (121.0 on doze 10) started to struggle with Google a few months ago. Sometimes the Google site doesn't load, sometimes it loads but doesn't connect (no auto-complete, no search) and if it does work the result links often don't load when clicked. It's like Google falls asleep and then, when it wakes up, all is fine, until it nods off again. I have followed advice provided, cleared cache, cleared cookies, removed plugins and extensions, reinitiated and reinstalled. Running in safe mode seems to help, as in pages seem to load faster, but sadly does not eliminate the problems. Other browsers on this machine are not affected. No time sync issues. Any suggestions? TIA

所有回覆 (17)

more options

Kevin McManus said

Running in safe mode seems to help, as in pages seem to load faster, but sadly does not eliminate the problems.

What security software are you running? What version of Win10? If Pro, can you fire up Windows Sandbox and see if you have the same issues in the VM? https://www.howtogeek.com/399290/how-to-use-windows-10s-new-sandbox-to-safely-test-apps/ Sounds like something is causing the issue if it works with Windows in Safe Mode.

由 jonzn4SUSE 於 修改

有幫助嗎?

more options

Kaspersky can cause performance issues if you have "Inject script into web traffic to interact with web pages" enabled and don't have the companion browser extension installed.

有幫助嗎?

more options

Thanks for your suggestions. Both machines are doze 10 home with Avast. I should have been more clear, I'm running Firefox in troubleshoot (safe) mode, not windows in safe mode. Everything seems to work just fine apart from Google which goes into some sort of sleep state if the browser is not used for some time, not sure how long but hours, not minutes, not days. I can persuade Google to wake up again with a few page reloads. Not sure that shift reloading makes any difference. Sometimes it takes several minutes of prodding to rouse it from its slumber.

有幫助嗎?

more options

Does it still happen in a new profile (without signing into sync account)? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

有幫助嗎?

more options

I have never created a profile so both machines say 'Profile: default'.

有幫助嗎?

more options

Does it still happen with Developer Edition?

有幫助嗎?

more options

Since Firefox works in Safe Mode, you should disable extensions one by one to see which one is the issue.

有幫助嗎?

more options

Thank you for your input. Running in safe (troubleshooting) mode seems to help, as in pages seem to load faster, but sadly does not eliminate the problems. I had already removed all extensions and plugins. I have now installed developer edition. After about an hour Google nodded off. If I open a new tab and click the Google bookmark it failed to load, timing out after about 30 seconds. A second click on the bookmark and Google loads. After a few hours all seemed well until again Google and Google links began struggling to load. I am not entirely certain but the developer edition seems to behave slightly better, as in a page refresh has so far been successful in getting Google and Google links to load successfully but clearly there is still a problem.

有幫助嗎?

more options

Developer edition has been running on my desktop machine for a few days now and it's really struggling to work with Google this morning. Certainly no better than the standard 121.0 Firefox. When I installed developer I did not import anything, all sites have required that I reload cookies, passwords and so on. Meanwhile the laptop 121.0 works without any problem on the same network. The only significant difference between the two is ethernet connection on the desktop and wifi connection on the laptop.

有幫助嗎?

more options

This could be a problem with the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You can try to set security.tls.enable_0rtt_data => false on the about:config page to disable this feature.

See also:

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet, select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

有幫助嗎?

more options

Thank you for getting back to me. I haven't used proxies this century :) I suspect that this problem started when my ISP installed 1G fibre. From my desktop (cat 6 connected) Google reports 600M each way with 1mS latency but from my laptop (wifi connected) Google reports 380 down 160 up and 3mS latency, so 0rtt sounds like it could be relevant, fingers crossed.

So Firefox 121.0 standard edition has been running for about 12 hours with 3 open tabs, none of which are Google. I have set security.tls.enable_0rtt_data to false, opened a new tab and clicked my Google bookmark. The page appeared instantly but the tab showed the oscillating blue dot for about 20 seconds. The page is however working, as in auto completing keystrokes. Let's leave a few Google result tabs open and see what happens after a few hours...

... more than 24 hours of sporadic use later and I'm pretty certain that 0rtt is the root cause :D

I'm incredibly grateful to cor-el for getting to the bottom of this one. Clearly this information needs to reach the developer team.

有幫助嗎?

more options

Sad to relate that several days on problems with Google loading and Google results loading have returned (only to desktop machine, only to Firefox browser).

I just checked that 0rtt was set to false, but this time I searched for 0rtt in the config and found that there is also network.http.http3.enable_0rtt. I have now also set this to false and will keep you updated (and fingers crossed).

有幫助嗎?

more options

I left a page of Google results open overnight and the first link I have clicked this morning to open in a new tab timed out after about 15 seconds leaving me with a blank page. After this Google seemed to wake up and return to normal service. I realise that this is not a massive annoyance, having to occasionally reload pages, but why only Firefox on the cat6 connected machine?

有幫助嗎?

more options

I have power-cycled the desktop machine (doze 10 home cat 6 connection) and fired up Chrome and Firefox 122.0b9 developer edition with network.http.http3.enable_0rtt and security.tls.enable_0rtt_data both set to false. After about 20 minutes of using both browsers, including Googling on Firefox, a Google result link (routed via googleadservices) on a freshly loaded page of search results which I asked Firefox to open in a new tab has timed out. It is not possible to reload a timed out tab but a second click in the results and the page loads successfully. Why do I get these problems only with Google on Firefox on this machine?

有幫助嗎?

more options

Google just refused to load. Took about 6 attempts to persuade a working Google page to appear.

有幫助嗎?

more options

Maybe try a VPN in Firefox in case your ISP is throttling the connection.

有幫助嗎?

more options

Surely ISP throttling would also affect other browsers? I've cat 6 connected my laptop and after using various browsers on both desktop and laptop for a couple of days only Firefox (regular and developer) on the desktop struggles with Google. I think that we can eliminate ISP throttling.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題