搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Google Advanced Search fails when using Firefox.

  • 3 回覆
  • 0 有這個問題
  • 21 次檢視
  • 最近回覆由 zeroknight

more options

I am using Firefox version 119.0.1 (64-bit) on Ubuntu 22.04. Using this version of Firefox, as well as previous versions for the last few months, I am having a persistent error when using Google Advanced Search. I enter search criteria into the field “Find pages with … all these words” and successfully progress through a chain of web pages. Previously I was able to backtrack to the previously mentioned field and find my search criteria, then edit the text, and carry out a modified search. For many months this field has been blank when returning to it. So it is now necessary to re-enter all text for a new search. This is very frustrating. I have experienced this problem on the three computers that I regularly use.

I have found that when I use the Google Chrome browser the problem goes away and searches progress normally. I would much prefer to use Firefox as my browser as I find its bookmark system superior. The truth is that if this problem with Firefox can’t be fixed soon I will be forced to migrate to Chrome. Can you please help me resolve this Firefox problem?

I am using Firefox version 119.0.1 (64-bit) on Ubuntu 22.04. Using this version of Firefox, as well as previous versions for the last few months, I am having a persistent error when using Google Advanced Search. I enter search criteria into the field “Find pages with … all these words” and successfully progress through a chain of web pages. Previously I was able to backtrack to the previously mentioned field and find my search criteria, then edit the text, and carry out a modified search. For many months this field has been blank when returning to it. So it is now necessary to re-enter all text for a new search. This is very frustrating. I have experienced this problem on the three computers that I regularly use. I have found that when I use the Google Chrome browser the problem goes away and searches progress normally. I would much prefer to use Firefox as my browser as I find its bookmark system superior. The truth is that if this problem with Firefox can’t be fixed soon I will be forced to migrate to Chrome. Can you please help me resolve this Firefox problem?

所有回覆 (3)

more options

This was fixed in version 120 (Bug 1850335).

more options

Just updated to Firefox snap in Ubuntu to 120.0.1 (64-bit). That alone did not fix the problem. I then followed discussion on bug 1850335 and saw suggestion to set docshell.shistory.bfcache.ship_allow_beforeunload_listeners = false This seems to have corrected the problem me. Thanks for the lead.

more options

It works for me on version 120.0.1 with docshell.shistory.bfcache.ship_allow_beforeunload_listeners set to default true.

Can you reproduce this in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.