Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Font size issue in the message view

  • 5 回覆
  • 1 有這個問題
  • 15 次檢視
  • 最近回覆由 david

more options

Dear support,

I installed recently Thunderbird 115.5.0 (64-bit) on my laptop running Debian 12.

I have a problem with the font size settings in the message view.

By default, the font size is very small. I can increase it by tuning in the top Menu. Tuning the Font size to 26 pt I get a readible text, see Picture 1. When I move to the next message, the font size becomes small again. Picture 2 shows when I moved and came back to the same message. The menu is shown, and the Font Size appears to be 26 pt in both screen shots.

I have set layout.css.devPixelsPerPx to -1

I have a userChrome.css, but it does not fix the font size in the message view. I wish I could know how to do that!

Thank you in advance for your help! Eric CM

Dear support, I installed recently Thunderbird 115.5.0 (64-bit) on my laptop running Debian 12. I have a problem with the font size settings in the message view. By default, the font size is very small. I can increase it by tuning in the top Menu. Tuning the Font size to 26 pt I get a readible text, see Picture 1. When I move to the next message, the font size becomes small again. Picture 2 shows when I moved and came back to the same message. The menu is shown, and the Font Size appears to be 26 pt in both screen shots. I have set layout.css.devPixelsPerPx to -1 I have a userChrome.css, but it does not fix the font size in the message view. I wish I could know how to do that! Thank you in advance for your help! Eric CM
附加的畫面擷圖

所有回覆 (5)

more options

It is all on pixels, not points.

I tried to view the images which I assume show some sort of comparison. But unfortunately they are so large I basically got lost on the arrow keys trying to scroll them.

The size at which messages are displayed is actually being set by the sender in all probability. You will see support forums and suggestion lists all over with folk demanding to be able to set font sizes in their mail. Microsoft fell over themselves to offer it and even now send huge emails full of cascading style sheets so folks can set the size of the font. It is just a shame their screen and yours is not the same to what look nice a corporate and professional on their system looks clownish or tiny on yours. Web developer is a profession. Email author is not despite both using the same technology, and it shows.

Essentially you can either use the CTRL++ and CTRL+- to zoom these message to make them readable, however that only stays set as long as you remain in the same message. You could override their font choices in settings. Search fonts, specify your choices in the advanced button and then deselect "allow messages to use other fonts"

The message you show appears to be plain text, so it is possible the setting in Fonts and colours for Default font may increase the text size of your plain text messages to something more reasonable to you. Your 26 might be a starting point there. Mine is 17 but that is a bit on the small side for me, but I get very few plain text messages.

more options

Dear Matt,

thank you for the explanation. I did not know about the appearance style and font size being embedded in the email itself. I understand plain text messages do not come with a predetermined font size. I wish those plain text message to be shown with reasonably large characters by default, without me adjusting with CTRL-+ each time.

The point I make is that if I rescale and increase the font size once using the top menu, this setting does not remain when moving to the next message. This is what the two pics are supposed to show. Let me attached those pictures again after trying to resolve the issue with their size.

My question now is : is there a way to define a minimum size in pixels for the characters used in the message view?

more options

AS I said, the font size in setting should set a size for plain text in my understanding. Did you try it?

more options

Yes (see screenshots), but weirdly, this does not seem to have an effect on the font size in the message view panel.

more options

Okay, let me add to the info that @matt shared with you. These additional steps have proved to create consistency in plain text messages and to HTML messages where the font size isn't embedded. And I attached examples of my own setting of Calibri 14 as my default. Here goes:

- in Tools>settings>general, set your default font. 
- then click the advanced button. Notice the drop-down menu at top. It probably says 'latin' or 'other writing systems' - this is IMPORTANT: 
- select 'latin from that menu, set your desired font and font size settings, click OK, 
- select 'otherwritingsystems' from the drop-down menu and set the IDENTICAL settings to what you did for Latin, and then click OK. In attached screenshots you will see my latin and otherwritingsystem match.  Notice I also set monospace font.
- and, if you have account set to compose HTML, then set that in tools>settings>composition to variable-width and medium font. (You would only change the HTML font setting if your intent is for recipient to receive your preferred font - not my personal recommendation.)
- Set Sending Format to 'automatic' 

With these settings, your compose window and your sent folders will match. And if you don't write HTML (e.g., bold, italic, color), none will be sent . If you do these settings once, your font will always be consistent. This does not protect you from someone sending you a message in some god-awful font with 30 pt size, but this does provide consistency.