搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

disable threads

  • 40 回覆
  • 193 有這個問題
  • 1382 次檢視
  • 最近回覆由 Toad-Hall

more options

Why is the VIEW menu missing the ability to turn off threads? Hate threads, always have, stupid idea. Sorry, but no. Where can I completely disable threads? I upgraded to 115 beta and all my accounts now have 'threads'... FML.

Why is the VIEW menu missing the ability to turn off threads? Hate threads, always have, stupid idea. Sorry, but no. Where can I completely disable threads? I upgraded to 115 beta and all my accounts now have 'threads'... FML.

所有回覆 (20)

more options

My guess is that you are using the hamburger menu. Try the view from menu bar.

有幫助嗎?

more options

I did read the previous threads about this...

From the view menu... where is the option to "don't thread messages"?

The percentage chance that I want to see threaded messages ever is .00000000000001%

Don't use Gmail or the gmail client for that reason - I use a 3rd party program on my mobile to read them completely unthreaded...

有幫助嗎?

more options

When you search, for example, for all emails from/to/cc Frank - the search results are threaded - across folders - you cannot tell if an individual emails is in inbox, sent, trash, or the Frank folder. This means, that you cannot move Frank's emails to Franks folder all at once, you need to expand each thread. How to disable threads in search results? For 20 years, I have been sorting the search results by folder, and moving all the sent, and inbox, emails to Frank, and leaving those in the trash - in the trash.

Who ever thought that threading emails across folders was a good idea?

由 murray16 於 修改

有幫助嗎?

more options

Try view>sort by>unthreaded

I share your view on Threading. Several recent changes have been widely criticized and I share the frustration.

有幫助嗎?

more options

Thanks for that pointer!

Already had View -> sort by -> unthreaded

Not sure what Thread -> "Ignored Threads" will do!

The short cuts to * expand and / collapse all threads does not work in the search results.

由 murray16 於 修改

有幫助嗎?

more options

I hate threads. Why would I want Thunderbird or anyone else for that matter, do my filing? When someone sends me an email, it should go to my INBOX. It should NOT follow the original email into the trash can. I don't let the mailman in my house and let him/her decide where to file my stuff. It goes in the mailbox.

All that being said, HOW do I disable all this "GROUPING" crap so I can direct filing myself?

有幫助嗎?

more options

Threading is just really crap an bloody annoying. Why can I not just disable it altogether? I usually reply and forward messages without wanting them to be linked in any way with the original message. Since the recent changes when I'm searching for an older message sent to somebody I do get a list of messages, thats ok. But when I'm clicking on the specific message I have been looking for instead of simply just opening it, I get a new list with all messages somehow linked to that one by thread etc. and I have to go through that list to find the message I originally already had clicked on...

有幫助嗎?

more options

I don't care for threading either. This may be more than you want to know, but it's my summary for threading:


This is the official (to my knowledge) documentation. Well worth the read https://support.mozilla.org/en-US/kb/message-threading-thunderbird

Here is my own documentation on threading, duplicating the above, but it may help: You need to highlight each folder and click View>sort by>unthreaded. If this applies to just a few folders, just repeat the process as necessary. If you have many folders or plan to add many new folders, you may wish a different approach, below:

More info: To change default for *new* folders, In config editor, you can change default that applies to NEW folders you set up: mailnews.default_view_flags 0=unthreaded

Config editor is available at Tools>settings>general and scroll to bottom right.

 ------------

To set many *existing* folders, follow these steps: (I creates a crude video that walks through the steps at

   https://davidkirk.org/SettingDefaultFolderView.mp4  that demonstrates the following steps:
   First, highlight a folder that you have set to unthreaded	
   In the Message List view, in the column header, on the far right, open the options button that shows    
    context menu. :
   At the very bottom is the option:
   -> "Apply current view to..."
   -> "Folder and its children..."
   -> Hover over an account
   -> In the next menu don't select a folder. Instead select the account name itself.

ALSO, for future installations of Thunderbird, 
- install Thunderbird and exit prior to setting up accounts
- create a simple text file with name of user.js with these lines: 
     // Set default threading to UNthreaded  ###   <== this line is optional, just for documentation
     user_pref("mailnews.default_view_flags", 0);
- copy the user.js file into the profile
- now, when you start Thunderbird, unthreading will be the default. Problem solved. 

有幫助嗎?

more options

I am a long time user of Mozilla Thunderbird and I donate regularly. In my business, emails are vital and I have them all for the last 23 years. I don't want then threaded or whatever the hell they are being called. It is critical for me to have them in date and time order. If there are those who want them threaded then let there be a simple setting switch that can be seen and understood. I've spent precious time going through the questions and answers and still have not found a way to turn this stuff off. I don't use gmail so that video is of no help, and the official version describes something that my version of Thunderbird 115.3.2 does not have.

Thunderbird - you said on the introduction to the latest update that you did not change our settings yet you have changed the viewing of our emails which is the most important of the settings. Please scrap this default threading and quickly.

有幫助嗎?

more options

I can only agree with the previous posts. The situation got even worse now that the search results are threaded too and I could not find any way to switch this off. Now, to search for e-mails with a certain person in a time range, I cannot simply sort by date and scroll to the range. Instead I have to use "before" and "after" criteria in the search which makes it way more complicated. There should be a possibility to disable thread with something like "View -> sort by -> unthreaded" for searches too.

有幫助嗎?

more options

Hate the threads thing as well. Cured this by clicking on the threads icon at the top of the column.

有幫助嗎?

more options

I really wish there was a global setting to turn off threading globally. I prefer chronological sort order and I suspect anybody older than 25 years old prefers it as well. Threading just doesn't work for me and absolutely hate it. When you're a task-oriented purpose with a first-in / first-out mindset, threading breaks this model and just messes with everything.

Please introduce a global setting to turn off threading.

有幫助嗎?

more options

There is a default setting. The problem is that it needs to be set to UNthreading before setting up an account. Feedback I have received indicates it will not be changed.

有幫助嗎?

more options

Jason Austin said

I am a long time user of Mozilla Thunderbird and I donate regularly. In my business, emails are vital and I have them all for the last 23 years. I don't want then threaded or whatever the hell they are being called. I don't use gmail so that video is of no help,

I also don't use Gmail, and thought the same thing when I opened the video, but what he shows works on T/bird too. I have the same issue as everybody else on this thread, Threads... Using that video I have GLOBALLY disabled threading.

Hope this helps.

有幫助嗎?

more options
In the video, I used a Gmail account, but the steps are identical for any account. Should you ever need to reinstall Thunderbird, the solution is to set the default prior to setting up accounts. An easy way (for future use) is to create a text file named user.js and place this content in it"
// Set default threading to UNthreaded  ###
user_pref("mailnews.default_view_flags", 0);

and copy to profile after installing Thunderbird.

有幫助嗎?

more options

david said

In the video, I used a Gmail account, but the steps are identical for any account. Should you ever need to reinstall Thunderbird, the solution is to set the default prior to setting up accounts. An easy way (for future use) is to create a text file named user.js and place this content in it"
// Set default threading to UNthreaded  ###
user_pref("mailnews.default_view_flags", 0);

and copy to profile after installing Thunderbird.

Hi David. You seem to know plenty about this problem. Thanks for the video BTW...

How can I stop threading in the results of a 'Search Messages' dialog box?

Cheers and thanks.

Chris.....

有幫助嗎?

more options

That 'should' be fixed if all related folders are unthreaded. That config setting only applies to new folders and one must make all those extra steps as in video to reset all folders. Others have reported the issue with search results being threaded and have indicated that the above steps correct it.

有幫助嗎?

more options

yes, count me in too.... threads are mainly useless, especially if you quote in the reply the previous message.... its also damn annoying to have to click 15 times to selected, view expand and read an email, when when before it was just one click.

有幫助嗎?

more options

david said

There is a default setting. The problem is that it needs to be set to UNthreading before setting up an account. Feedback I have received indicates it will not be changed.

ummm, NO??? i never had threading ON to begin with. it was chosen for me, with the update.

有幫助嗎?

more options

Threads keep coming back in Gmail even after specifying View>Sort>Unthread. Mozilla - get rid of threads!

有幫助嗎?

  1. 1
  2. 2
問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題