搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

"Temp" Images not loading/saving

  • 5 回覆
  • 0 有這個問題
  • 1 次檢視
  • 最近回覆由 Microwave

more options

Certain images are never created or loaded in my browser. Youtube thumbnails, for example, display as only light grey squares. I thought maybe my addons might be causing this, but the only one that seems capable is uBlock Origin, and I even disabled it completely. Anyone know what could cause this? Surely its a caching issue or something. I can include images if anyones curious.

Certain images are never created or loaded in my browser. Youtube thumbnails, for example, display as only light grey squares. I thought maybe my addons might be causing this, but the only one that seems capable is uBlock Origin, and I even disabled it completely. Anyone know what could cause this? Surely its a caching issue or something. I can include images if anyones curious.

被選擇的解決方法

Go to about:config in the address bar and make sure that image.webp.enabled is default true.

從原來的回覆中察看解決方案 👍 1

所有回覆 (5)

more options

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.


Make sure you haven't enabled High Contrast mode in the OS settings.

Make sure you allow pages to choose their own colors as this affects background images.

  • Settings -> General -> Language and Appearance -> Colors -> Manage Colors
    "Override the colors specified by the page with your selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

ty for responding! sorry it took me a while to get back haha

it seems that the images that arent loading arent in the network monitor. i guess my browser never requests them in the first place? anybody know why it might be doing this?

more options

and ty so much for providing so many resources :)

more options

選擇的解決方法

Go to about:config in the address bar and make sure that image.webp.enabled is default true.

more options

oh that fixed it!!! ty SO much <3<3<3