搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Widevine plugin not installing

more options

I installed Firefox-ESR on my Raspberry PI and noticed that I cannot play Udemy videos. After some research I found that the Widevine plugin is missing and the OpenH264 Video Codec is also not installed. Following the instructions from similar issues didn't solve the problem. I ticked off and on the "Play DRM-controlled content" button but this only brings the widevine plugin for a moment and after that it disappears. In the network tab I see no activity when click on this button, i.e. Firefox does not send requests.

Additionally the OpenH264 Video Codec is not installed and never installs.

Any ideas how to solve this?

I installed Firefox-ESR on my Raspberry PI and noticed that I cannot play Udemy videos. After some research I found that the Widevine plugin is missing and the OpenH264 Video Codec is also not installed. Following the instructions from similar issues didn't solve the problem. I ticked off and on the "Play DRM-controlled content" button but this only brings the widevine plugin for a moment and after that it disappears. In the network tab I see no activity when click on this button, i.e. Firefox does not send requests. Additionally the OpenH264 Video Codec is not installed and never installs. Any ideas how to solve this?
附加的畫面擷圖

所有回覆 (13)

more options

You likely do not have any use of the OpenH264 plugin anyways. https://support.mozilla.org/en-US/kb/open-h264-plugin-firefox

Since you are using a Linux distro. What you may actually need to have installed is FFmpeg package as it provides the codecs needed for HTML5 players used for video, audio and games.

This may be why you are not able to play Udemy videos.

more options

As far as I see the FFmpeg package is installed. I also checked the following commands: ffmpeg -encoders ffmpeg -decoders

and they show the encoders and decoders are installed. In fact the system is able to play Youtube and other videos but the Udemy does not run - I receive an error message (see second picture below).

more options

v.grozev said

I ticked off and on the "Play DRM-controlled content" button but this only brings the widevine plugin for a moment and after that it disappears. In the network tab I see no activity when click on this button, i.e. Firefox does not send requests.

When you say it brings up the plugin for a moment, do you mean an Infobar appears below the toolbars? Or in other words, it isn't appearing on the Plugins list section of the Add-ons page and then disappearing from there.

Looking at the source code for Firefox 102 ESR (line 22), it looks like Firefox tries to retrieve the Widevine plugin from this URL:

https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.2557.0-linux-x64.zip

When I submit that in the address bar, the server sends a 302 temporary redirect (Location header) to:

https://r2---sn-n4v7snll.gvt1.com/edgedl/widevine-cdm/4.10.2557.0-linux-x64.zip?cms_redirect=yes&mh=w2&mip=2600:1700:5430:1240:bdbc:df9d:311b:87e3&mm=28&mn=sn-n4v7snll&ms=nvh&mt=1691341234&mv=m&mvi=2&pl=45&rmhost=r5---sn-n4v7snll.gvt1.com&shardbypass=sd&smhost=r5---sn-n4v7snee.gvt1.com

Are you able to retrieve either of those as downloads? If not, is it possible you (your Pi) is blocking that server in some manner?

more options

jscher2000 - Support Volunteer said

When you say it brings up the plugin for a moment, do you mean an Infobar appears below the toolbars? Or in other words, it isn't appearing on the Plugins list section of the Add-ons page and then disappearing from there.

In my initial question I posted two screenshots - check the second one, this is how the Widevine plugin appears in the plugins section. When I uncheck the DRM checkbox Firefox makes one request which has nothing to do with the links where the plugin is located (it's in the attached screenshot).

more options

I don't think the tab-level dev tools would show background request for Widevine. I don't even know if it would appear in the Browser Console (Ctrl+Shift+J), which monitors requests from processes other than the particular tab.

What happens when you try to enable the plugin on the Add-ons page by clicking the ••• button and choosing Always Activate? Or is that not available?

Any result from the URL test?

more options
more options

Thank you for the support guys! Linux is a whole new universe to me but after some trial and error attempts I managed to make it work by following these steps:

1. Installed the Widevine plugin as explained here. After that I found it resides in /opt/WidevineCdm

2. Downloaded this file https://drive.google.com/file/d/1dDtsiUb_FWlbi6TZOxgrUIsC3l-Hr126/view?usp=drive_link

3. Extracted the file contents and ran the script register_widevine_firefox which was inside

Out of curiosity I checked the script and saw what it does was to create symlink/reference to the /opt/WidevineCdm folder with this code: ln -s /opt/WidevineCdm/firefox/gmp-widevinecdm "${HOME}/.mozilla/firefox/${prof}/gmp-widevinecdm"

However, I still do not see the Widevine plugin installed in the browser plugins section (about:plugins).

由 v.grozev 於 修改

more options

Does your about:config show these preferences that are added during a typical installation on Windows --

media.gmp-widevinecdm.abi media.gmp-widevinecdm.hashValue media.gmp-widevinecdm.lastDownload media.gmp-widevinecdm.lastInstallStart media.gmp-widevinecdm.lastUpdate media.gmp-widevinecdm.version

-- or just the two default preferences:

media.gmp-widevinecdm.enabled => true media.gmp-widevinecdm.visible => true

I don't know which ones are critical to getting Firefox working with the plugin, but this one might be needed to find the plugin in the directory of the same name:

media.gmp-widevinecdm.version => 4.10.2557.0

more options

Note that media.gmp-widevinecdm.version need to match the widevine version folder in /opt/WidevineCdm/firefox/gmp-widevinecdm/

more options

jscher2000 - Support Volunteer said

Does your about:config show these preferences that are added during a typical installation on Windows -- media.gmp-widevinecdm.abi media.gmp-widevinecdm.hashValue media.gmp-widevinecdm.lastDownload media.gmp-widevinecdm.lastInstallStart media.gmp-widevinecdm.lastUpdate media.gmp-widevinecdm.version -- or just the two default preferences: media.gmp-widevinecdm.enabled => true media.gmp-widevinecdm.visible => true I don't know which ones are critical to getting Firefox working with the plugin, but this one might be needed to find the plugin in the directory of the same name: media.gmp-widevinecdm.version => 4.10.2557.0

I cannot see any of these settings in about:config. Neither the ones from the first group nor from the second. Should I add them (at least the last two)?

more options

Yes, I think you should try adding three of them:

First, could you cross-check your symlink. The directory inside

gmp-widevinecdm

should be named with the version number, most likely 4.10.2557.0

Does that match up with yours?

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste media.gmp-widevinecdm.version

  • Firefox should display a bar to create a new preference. Select String then click the + button.
  • Paste 4.10.2557.0 (or whatever the actual folder name is that you found) and press Enter or click the blue check mark button to save the change.

(3) In the search box in the page, type or paste media.gmp-widevinecdm.enabled

  • If this preference does not exist, Firefox should display a bar to create a new preference. Keep the selection on Boolean then click the + button.
  • If the value isn't automatically set to true, toggle the value to true.

(4) In the search box in the page, type or paste media.gmp-widevinecdm.visible

  • If this preference does not exist, Firefox should display a bar to create a new preference. Keep the selection on Boolean then click the + button.
  • If the value isn't automatically set to true, toggle the value to true.
more options

The version I see in the manifest file located in /opt/WidevineCdm is 4.10.2252.0 After I added these 3 preferences and now I can see the Widevine plugin in the Plugins section (see the screenshot). However the outcome of that intervention was that the Udemy videos stopped playing.

I had to remove these 3 entries, restart FF and I am able again to play Udemy.

more options

Was there any specific error message in the player?

Do you think it might work better if you copy the contents of

/opt/WidevineCdm/firefox/gmp-widevinecdm

to

${HOME}/.mozilla/firefox/${prof}/gmp-widevinecdm

instead of using a symlink? (On Windows, a shortcut isn't always as good as the real thing, but I don't know about Linux.)