搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

YouTube only playing audio, not video

  • 2 回覆
  • 0 有這個問題
  • 34 次檢視
  • 最近回覆由 zaw

more options

The YouTube videos load in troubleshoot mode, so I reopened Firefox and disabled all extensions. That did not help, so I uninstall all extensions. That does not work either. Other browsers work, but Firefox does not.

The YouTube videos load in troubleshoot mode, so I reopened Firefox and disabled all extensions. That did not help, so I uninstall all extensions. That does not work either. Other browsers work, but Firefox does not.
附加的畫面擷圖

所有回覆 (2)

more options

See:


You can check the Web Console.

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting to make changes effective.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

more options

Disabling hardware acceleration did the trick. However, when I play any YouTube video, my computer goes loud as it takes up so much CPU. In task manager, Firefox takes a whopping 25% CPU when I play a video. I don't think it's my computer that needs upgrading, because it's an i9-13900 with an RTX 4080. I cannot imagine why Firefox needs that much computational power from a 13th gen i9. And yes, I have all the latest updates (Windows, drivers, GPU drivers) installed.

What makes it so that running Firefox in troubleshoot mode allows hardware acceleration and work like other browsers? This is extremely frustrating as it seems to be only Firefox and I do not want to jump ship to Chrome or worse, Edge.