搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

colors of links are incorrect

  • 6 回覆
  • 0 有這個問題
  • 50 次檢視
  • 最近回覆由 jOhn+ny

more options

The link colors are suddenly incorrect. Normally the links are blue and the visited links are purple, but now they are pastel light-blue and pastel pink. This problem is not in Edge or Chrome. I am using Firefox 113.0.1

I have tried - rebooting windows - windows shutdown, wait, restart - changing the firefox website appearance and themes (auto, dark, light) Still no solution. Any ideas? Thanks.

The link colors are suddenly incorrect. Normally the links are blue and the visited links are purple, but now they are pastel light-blue and pastel pink. This problem is not in Edge or Chrome. I am using Firefox 113.0.1 I have tried - rebooting windows - windows shutdown, wait, restart - changing the firefox website appearance and themes (auto, dark, light) Still no solution. Any ideas? Thanks.
附加的畫面擷圖

被選擇的解決方法

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
從原來的回覆中察看解決方案 👍 0

所有回覆 (6)

more options

Make sure you haven't enabled High Contrast mode in the OS settings.

Make sure you allow pages to choose their own colors.

  • Settings -> General -> Language and Appearance -> Colors -> Manage Colors
    "Override the colors specified by the page with your selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

more options

Hi co-rel, thanks for answering. The "Override the colors specified by the page" was already set to None. Changing it back and forth has no effect.

I was not having this problem last week, and I am not aware of making any changes to any settings.

I share a Logitech K780 Keyboard between two laptops; on the one Laptop I have this problem only starting this week, on the other I do not have the problem.

Thanks for any further hints you may have.

more options

It is possible that your browser is using the colours for dark mode. Enter about:config in the address bar and you can see these preferences. browser.anchor_color browser.anchor_color.dark browser.visited_color browser.visited_color.dark

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

more options

選擇的解決方法

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

You can check the :visited color in the Inspector.

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

more options

@Terry - I checked the about:config, and those values seem to be correct. Thanks for the hint anyway.

@cor-el - I started in Troubleshoot Mode and the problem was resolved. I then restarted in normal mode and the problem remained resolved. However, I didn't knowingly change anything - settings still the same, no add-ons or extensions changed. Just start in Troubleshoot, then start in normal mode. Using the Inspector is now moot.

Anyway, I am a happy camper again - thanks for your help. ciao -jOhn+ny-

由 jOhn+ny 於 修改