Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How to disable modifier keys changing the behaviour of urlbar?

  • 無回覆
  • 0 有這個問題
  • 6 次檢視
more options

I've just discovered, that by typing text into urlbar and then clicking enter while holding SHIFT or ALT leads to a different behavior by opening tab in new window or new tab respectively.

But I have custom layout with caps+space acting as enter via xkb 8-level mapping, and that enter always opens new tabs. I suspect what is happening is that firefox thinks that I have alt down when the keyboard state is in third level. But I don't really use those modifiers so is it possible to just disable this behavior and open everything in same tab?

I've just discovered, that by typing text into urlbar and then clicking enter while holding SHIFT or ALT leads to a different behavior by opening tab in new window or new tab respectively. But I have custom layout with caps+space acting as enter via xkb 8-level mapping, and that enter always opens new tabs. I suspect what is happening is that firefox thinks that I have alt down when the keyboard state is in third level. But I don't really use those modifiers so is it possible to just disable this behavior and open everything in same tab?