Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Don't want Amazon in my Search bar

  • 6 回覆
  • 0 有這個問題
  • 9 次檢視
  • 最近回覆由 BuddyL

more options

I customised my Search so that the default is DuckDuckGo and I've removed all the other search engines in Search Shortcuts. Yet, every time I type into the Firefox address bar, both Amazon and Wikipedia still show up, despite the fact that neither should be an option.

I customised my Search so that the default is DuckDuckGo and I've removed '''all '''the other search engines in Search Shortcuts. Yet, every time I type into the Firefox address bar, both Amazon and Wikipedia still show up, despite the fact that neither should be an option.
附加的畫面擷圖

所有回覆 (6)

more options

If this firefox FAQ doesn't work then you need to clean the cache/history to remove it from showing up. But if you go back to Amazon or a search clicks on Amazon - it will be listed in the search URL again.

https://support.mozilla.org/en-US/kb/how-clear-firefox-cache https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox

If you want no cache and history then you will have nothing searched saved in the url location. This next options will remove everything as well.

https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox

由 Dropa 於 修改

more options

I delete the cache, cookies, search, data after every session. That's not the problem.

more options

If you search each session without closing Firefox with those settings in place it will be there until you close the Browser and exit then it clears out that data and reopen and that should remove those search.

more options

Again: I already clear out all of those thing after every session at the end of everyday. And that's before I run all my virus- and malware-scanners and delete every temp file on my computer.

I do this everyday, so that's not it.

more options

To remove a search engine, follow these steps: In the Menu bar at the top of the screen, click Firefox and select Preferences. In the Settings tab that opens, click on Search in the left pane. Under Search Shortcuts, click on the search engine you want to remove. Click the Remove button to take it off your list.

Regards, Will

more options

I literally mentioned that in my initial question. Does any have an answer I haven't already detailed??