搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

FireFox latest ver, download window resize to smaller fail - now 1/4-ish screen

  • 8 回覆
  • 8 有這個問題
  • 237 次檢視
  • 最近回覆由 tony_w

more options

FireFox: 107.0 (64 bit) Mozilla FireFox for Linux Mint OS: Linux Mint 21 Cinnamon

Issue: On this FireFox latest version, the download window cannot be resized to smaller than (roughly) 1/4 of entire screen. (screen-shot attached.)

Attempted: Mouse left-click grab of all corners & sides to drag window smaller - failed!

Note: Download window can be resized *bigger*, showing this window has now been coded with a very large minimum size that is almost 1/4 of full screen

- this was not the case in previous versions.

Micro-annoyances add up, people switch to Chrome (sorry to use the "C" word!)

FireFox: 107.0 (64 bit) Mozilla FireFox for Linux Mint OS: Linux Mint 21 Cinnamon Issue: On this FireFox latest version, the download window cannot be resized to smaller than (roughly) 1/4 of entire screen. (screen-shot attached.) Attempted: Mouse left-click grab of all corners & sides to drag window smaller - failed! Note: Download window can be resized *bigger*, showing this window has now been coded with a very large minimum size that is almost 1/4 of full screen - this was not the case in previous versions. Micro-annoyances add up, people switch to Chrome (sorry to use the "C" word!)
附加的畫面擷圖

被選擇的解決方法

Thanks to all who suggested the userChrome.css work-around!

I found my profile folder via: https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data

In my found profile folder, I created a folder named: chrome

and in that folder I created a text file called: userChrome.css

contents I put in that file:

/* Reduce the minimum size of Download/Library window to a small value */

window#places {

min-width: 100px !important;
min-height: 300px !important;

}

in a new FireFox tab I typed: about:config (Click the button accepting the risk.)

In the search box type: userprof

then Double-click to "true": toolkit.legacyUserProfileCustomizations.stylesheets

restart firefox

從原來的回覆中察看解決方案 👍 0

所有回覆 (8)

more options

You may have to resort to userChrome.css.

https://support.mozilla.org/en-US/questions/1397089

有幫助嗎?

more options

See also:

  • /questions/1396924 Library window cannot be sized smaller than HUGE, Firefox 107.0 64 bit Windows 10 Pro

有幫助嗎?

more options

選擇的解決方法

Thanks to all who suggested the userChrome.css work-around!

I found my profile folder via: https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data

In my found profile folder, I created a folder named: chrome

and in that folder I created a text file called: userChrome.css

contents I put in that file:

/* Reduce the minimum size of Download/Library window to a small value */

window#places {

min-width: 100px !important;
min-height: 300px !important;

}

in a new FireFox tab I typed: about:config (Click the button accepting the risk.)

In the search box type: userprof

then Double-click to "true": toolkit.legacyUserProfileCustomizations.stylesheets

restart firefox

有幫助嗎?

more options

I have this same problem on my Mac, but the solution doesn't work. I create the chrome folder (inside my Firefox profile located at ~/Library/Application Support/Firefox/Profiles), put the userChrome.css file in there, toggle the toolkit.legacyUserProfileCustomizations.stylesheets setting to true, and restart Firefox. Still can't reduce the size of the downloads window.

Any idea what I'm doing wrong?

有幫助嗎?

more options

Among other things, check that you have the file name correct.

https://www.userchrome.org/what-is-userchrome-css.html

有幫助嗎?

more options

I assume it's spelled correctly and in the right place because I can see it listed in the Browser Toolbox. So it looks like it's loading but it's not working.

有幫助嗎?

more options

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

有幫助嗎?

more options

I appreciate the replies, but as I already said I put the userChrome.css file (correctly spelled) in the right place, I can see it has been loaded (via Browser Toolbox), I have set toolkit.legacyUserProfileCustomizations.stylesheets to true, and I restarted Firefox.

This seems to have worked for some people, but not for me. I thought maybe I skipped a step, but it sure looks like I've done everything correctly.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題