搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

i can't play some (but not all) youtube videos with firefox 106.0.3

  • 10 回覆
  • 0 有這個問題
  • 36 次檢視
  • 最近回覆由 ruthtoby

more options

i can't play some (but not all) youtube videos. they do play on other web browsers.

the message is "an error occured, please try again later. playback ID is ... " 

i'm using firefox 106.0.3 on linux suse tumbleweed. Before I upgraded to both of these the same videos were playing ok.

i can't play some (but not all) youtube videos. they do play on other web browsers. the message is "an error occured, please try again later. playback ID is ... " i'm using firefox 106.0.3 on linux suse tumbleweed. Before I upgraded to both of these the same videos were playing ok.

被選擇的解決方法

hi @jonzn4SUSE thanks for this help. Yes i'm using X.11 graphics platform. Following your instructions got me nearly to a solution, it did install packman repos and libraries. but still the same problem playing the videos.

There has also been a thread on opensuse about the exact problems that i was facing (https://forums.opensuse.org/showthread.php/568822-firefox-having-problems-with-codecs), and here they suggest the following zypper command - in a post made 9th may 2022 zypper install --from packman libavcodec59

so after the install you suggested I ran this zypper install, which basically changes vendor for 9 pachages.

and now my problems seem to have been solved, hooray. Along the way for both the installation and the zypper there were many times when packages were duplicated and I had to choose to install the new versions.

從原來的回覆中察看解決方案 👍 1

所有回覆 (10)

more options

Could you double-check that the FFmpeg package is installed on your Linux (this is outside Firefox, but Firefox uses it for MPEG decoding).

I have a copy of the old YouTube HTML5 support detection page on my website. Normally everything says either supported or probably. Does yours show any gaps:

https://www.jeffersonscher.com/sumo/html5-video.html

有幫助嗎?

more options

Hi @jscher2000 - thank you for getting back to me. FFmpeg is installed on my system. The HTML5 detection page shows results as in the uploaded image, i.e. supported, probably, probably, supported, supported, supported

i can play some videos ok, it's just some of the videos from a set by OpenEMR that no longer play, for example https://www.youtube.com/watch?v=sHLG_cuH_n0

does this all give any further clues? I appreciate your help, ruth

有幫助嗎?

more options

When I right-click the video player and check "Stats for nerds" it tells me the video was compressed with AVC, which is think is one of the standard MP4 codecs. I don't know what all the numbers mean.

You could open the Web Console (Ctrl+Shift+K) in the lower part of the tab to see whether it lists any more errors related to the video.

有幫助嗎?

more options

thanks for these strategies.

the web console is showing errors - e.g.

"This error message will be blank when privacy.resistFingerprinting = true.  If it is really necessary, please add it to the whitelist in MediaError::GetMessage: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - mozilla::MediaResult mozilla::FFmpegDataDecoder<59>::InitDecoder(): Couldn't open avcodec" 

several times, then

" The resource at “https://i.ytimg.com/generate_204” preloaded with link preload was not used within a few seconds. Make sure all attributes of the preload tag are set correctly." about 3 times.

which does point to problems with FFmpeg as you suggested.

another interesting thing is that although i can't play the video, when i drag the timer along the bar (not sure what this is called) individual frames are displayed correctly.

有幫助嗎?

more options

The first part of that is new to me:

ruthtoby said

This error message will be blank when privacy.resistFingerprinting = true. If it is really necessary, please add it to the whitelist in MediaError::GetMessage: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - mozilla::MediaResult mozilla::FFmpegDataDecoder<59>::InitDecoder(): Couldn't open avcodec

If you have set privacy.resistFingerprinting to true in about:config, it may be saying either that it has some effect on this problem or that it affects how error messages are reported. But either way, it sounds like the connection between Firefox and FFmpeg isn't working normally.

I think there were some other recent reports of video decoding issues where the thumbnails could be seen along the timeline. You might search here or on https://www.reddit.com/r/firefox/ for any recent Linux-related threads about video playback issues.

有幫助嗎?

more options

i'll look around on other forums, if i can't find a solution i might revert to opensuse leap, where the videos were playing ok, albeit an earlier version of the o.s.

i turned off 'advanced tracking protection' for youtube, which includes fingerprinters, but it made no difference.

again, many thanks for your help

由 ruthtoby 於 修改

有幫助嗎?

more options

Hi Jefferson,

just to let you know there is a thread in the opensuse forum where other people have described exactly the problem i have, with the same error message. It appears to have started giving problems early this year on opensuse tumbleweed (and it happened to me when i updated to tumbleweed) I'll read through the thread and, hopefully, find a solution. the thread is at https://forums.opensuse.org/showthread.php/568822-firefox-having-problems-with-codecs/page2 . a bit busy at the moment but hope to get back to this next week.

ruth

有幫助嗎?

more options

We are on the same OS so the ffmpegs and libavs should be the same as long as you have the packman repo installed. see screenshot

This is the site I always use after an OS install to get packman with just a few clicks. https://www.opensuse-community.org/


Operating System: openSUSE Tumbleweed 20221109 KDE Plasma Version: 5.26.2 KDE Frameworks Version: 5.99.0 Qt Version: 5.15.7 Kernel Version: 6.0.7-1-default (64-bit) Graphics Platform: X11 Processors: 8 × Intel® Xeon® CPU E3-1535M v6 @ 3.10GHz Memory: 62.7 GiB of RAM Graphics Processor: Mesa Intel® HD Graphics P630 Manufacturer: HP Product Name: HP ZBook 17 G4

有幫助嗎?

more options

Also, what desktop are your using? X11 or Wayland?

有幫助嗎?

more options

選擇的解決方法

hi @jonzn4SUSE thanks for this help. Yes i'm using X.11 graphics platform. Following your instructions got me nearly to a solution, it did install packman repos and libraries. but still the same problem playing the videos.

There has also been a thread on opensuse about the exact problems that i was facing (https://forums.opensuse.org/showthread.php/568822-firefox-having-problems-with-codecs), and here they suggest the following zypper command - in a post made 9th may 2022 zypper install --from packman libavcodec59

so after the install you suggested I ran this zypper install, which basically changes vendor for 9 pachages.

and now my problems seem to have been solved, hooray. Along the way for both the installation and the zypper there were many times when packages were duplicated and I had to choose to install the new versions.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題