搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Did not connect: Potential Security Issue since upgrading to version 105

  • 9 回覆
  • 2 有這個問題
  • 2 次檢視
  • 最近回覆由 jonzn4SUSE

more options

I am getting a stack of these errors preventing me from browsing to secure websites which includes google.com. Luckily my Chrome Browser and Edge Browser work fine. This is just another nail in the coffin for me to close the door on this browser which is just getting more and more unreliable.

For now, I have migrated to Chrome to allow me to go about my business of without Firefox telling me Google.com and many other secure sites are unsafe to browse!

Please bring back the override and accept the risk. I would rather have a warning and transfer risk to me rather than have a draconian rule telling me to use a different browser to resolve the issue. For now, you have forced my choice.

I cannot believe I am the only User to experience this issue. I do not want to delete all my cookies etc as I want to be selective in what I delete but again, this option has been taken away from me as well.

Looking forward to a solution.

Thanks.

I am getting a stack of these errors preventing me from browsing to secure websites which includes google.com. Luckily my Chrome Browser and Edge Browser work fine. This is just another nail in the coffin for me to close the door on this browser which is just getting more and more unreliable. For now, I have migrated to Chrome to allow me to go about my business of without Firefox telling me Google.com and many other secure sites are unsafe to browse! Please bring back the override and accept the risk. I would rather have a warning and transfer risk to me rather than have a draconian rule telling me to use a different browser to resolve the issue. For now, you have forced my choice. I cannot believe I am the only User to experience this issue. I do not want to delete all my cookies etc as I want to be selective in what I delete but again, this option has been taken away from me as well. Looking forward to a solution. Thanks.
附加的畫面擷圖

所有回覆 (9)

more options

Who is the issuer of the certificate if you check this via the links at the bottom of the error page ?

You can check details about the issuer of the certificate and the certificate chain.

  • click the "Advanced" button on the error page to show more detail
  • click the blue "View Certificate" text to inspect the certificate chain in the Certificate Viewer

有幫助嗎?

more options

Hi, Thanks for your prompt response. I think the important point to remember that ONLY Firefox is having issues with the Certificates. I have included an image showing the google Certs which by the way are the same ones recognised correctly in the other Browsers. I used the Google one as an example because it is trusted worldwide just in case there was some query about the validity of the Cert.

Let me know if you need more info.

Thank you

有幫助嗎?

more options

Hi, in the end I used the Certs for Google from the Chrome Browser and imported them into Firefox. This corrected the problem. This indicates that Firefox is not pulling down the Certificates into its cache correctly.

有幫助嗎?

more options

Interesting... I just booted to Win7, haven't used it for sometime, but I was getting ssl errors going to anything google related. Had to clear cache and restart Firefox to fix the error.

有幫助嗎?

more options

The interesting thing is that the problem occurs only with the Firefox Browser. The other two well known brands don't have any issues and based on that, it points to a Firefox specific issue.

Thanks for testing and also experiencing a problem. Strange that Firefox has difficulty processing the globalsign Certs.

有幫助嗎?

more options

Searching from here in California, Google's server sends me a different certificate than it sends you, one that is a wildcard cert for a vast swath of its infrastructure. It automatically validates to a root certificate stored in Firefox 105. (Comparison attached)

I'm not sure how to explain the different one you're getting, but it makes me suspicious about an intermediary. To instruct Firefox to bypass any system-defined proxy server that might be involved in swapping the cert:

Open the Settings page using either:

  • "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • type or paste about:preferences into the address bar and press Enter to load it

In the very tiny search box at the top of the page, type proxy and Firefox should filter to the "Network Settings" section.

Click the Settings button, select "No Proxy" near the top of the dialog, and click OK near the bottom of the dialog.

有幫助嗎?

more options

Try to rename the cert9.db file (cert9OLD.db) and remove a possible previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

有幫助嗎?

more options

Hi All,

Thank you for your prompt replies and suggestions. As I was able to get things sorted by importing the Cert from Chrome, it resolved my immediate problem with the Globalsign Certs. Something got corrupted with the cached Certs being used for validation. I feel the suggestions provided by Cor-el and jscher2000 would have helped to resolve the issue if I had not done what I did.

I would suggest that these options are worthy of being added into the the troubleshooting options which would help others in the future. This problem was not about incorrect Certs, just an issue with corruptions within the the cached data for Certs.

Thanks,

Dave

有幫助嗎?

more options

Good job... Now mark it as resolved and get back to it.  ;-)

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題