搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Tabbs on Bottom

  • 13 回覆
  • 0 有這個問題
  • 60 次檢視
  • 最近回覆由 Anne's Place

more options

Woke up this morning, opened up Firefox and the Trolls have been busy rearranging things during the night. My profile manager disappeared, but I was able to fix that. Now my tabs are out of place and I cannot find what to do to put the Tabs back on bottom, "The way they Should be". Help, please.

Anne,

Also, I am not real computer literate, so draw pictures if necessary.

Thank you.

Woke up this morning, opened up Firefox and the Trolls have been busy rearranging things during the night. My profile manager disappeared, but I was able to fix that. Now my tabs are out of place and I cannot find what to do to put the Tabs back on bottom, "The way they Should be". Help, please. Anne, Also, I am not real computer literate, so draw pictures if necessary. Thank you.

所有回覆 (13)

more options

Hi Anne, the only way to move the tabs from their normal location to a different one is a group of rules in a userChrome.css file.

Are you using a different Firefox profile than you were using before? That would explain losing customizations like a userChrome.css file, but even your add-ons and pinned tabs on the new tab page may not have your customizations.

Two places to check:

(1) Is there a new "Old Firefox Data" folder on your Windows desktop? This is created during a Firefox Refresh. You can check inside to see how fresh the files are, and whether your old chrome folder is in there.

(2) Can you switch to an older profile using the About Profiles page? Here's how to check that:

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

This page should list at least one profile and could list many. (Each profile has two folders and one or more buttons. Do not use any Remove buttons!)

The profile that Firefox is currently using will have this:

This is the profile in use and it cannot be deleted.

Do you have any other profile(s) listed on this page? If so, you can check whether it is the one you were using recently by clicking its Launch profile in new browser button.

If it isn't what you want, simply close that new window.

If it IS what you want, back on the about:profiles page, click the Set as default profile button for that profile so Firefox uses it automatically at the next startup.

有幫助嗎?

more options

I am using Firefox 104.0.2 We have 3 profiles within Firefox. My husbands is working just fine. I did not know if there was a "tune up for Chrome that might fix this or not. I know previously you sent a file or script that I was able to copy and past, I just don't know what to do now.

有幫助嗎?

more options

The "Tune-up" removes custom files, so do not choose that option if you see it.

Can you can roll back to what you had before by choosing a different profile on about:profiles, or are those already spoken for?

If not, do you have an Old Firefox Data folder?

有幫助嗎?

more options
/* Source file https://github.com/MrOtherGuy/firefox-csshacks/tree/master/chrome/tabs_on_bottom.css made available under Mozilla Public License v. 2.0
See the above repository for updates as well as full license text. */

/* Modify to change window drag space width */
/*
Use tabs_on_bottom_menubar_on_top_patch.css if you
have menubar permanently enabled and want it on top
*/

/* IMPORTANT */
/*
Get window_control_placeholder_support.css
Window controls will be all wrong without it.
Additionally on Linux, you may need to get:
linux_gtk_window_control_patch.css
*/

:root{ --uc-titlebar-padding: 0px; }
@media (-moz-os-version: windows-win10){
:root[sizemode="maximized"][tabsintitlebar]{ --uc-titlebar-padding: 8px }
}
#toolbar-menubar[autohide="true"] > .titlebar-buttonbox-container,
#TabsToolbar > .titlebar-buttonbox-container{
position: fixed;
display: block;
top: var(--uc-titlebar-padding,0px);
right:0;
height: 40px;
}
/* Mac specific. You should set that font-smoothing pref to true if you are on any platform where window controls are on left */
@supports -moz-bool-pref("layout.css.osx-font-smoothing.enabled"){
:root{ --uc-titlebar-padding: 0px !important }
.titlebar-buttonbox-container{ left:0; right: unset !important; }
}

:root[uidensity="compact"] #TabsToolbar > .titlebar-buttonbox-container{ height: 32px }

#toolbar-menubar[inactive] > .titlebar-buttonbox-container{ opacity: 0 }

#navigator-toolbox{ padding-top: var(--uc-titlebar-padding,0px) !important; }

.titlebar-buttonbox-container > .titlebar-buttonbox{ height: 100%; }

#titlebar{
-moz-box-ordinal-group: 2;
-moz-appearance: none !important;
--tabs-navbar-shadow-size: 0px;
}

.titlebar-placeholder,
#TabsToolbar .titlebar-spacer{ display: none; }
/* Also hide the toolbox bottom border which isn't at bottom with this setup */
#navigator-toolbox::after{ display: none !important; }

@media (-moz-gtk-csd-close-button){ .titlebar-button{ -moz-box-orient: vertical } }

/* These exist only for compatibility with autohide-tabstoolbar.css */
toolbox#navigator-toolbox > toolbar#nav-bar.browser-toolbar{ animation: none; }
#navigator-toolbox:hover #TabsToolbar{ animation: slidein ease-out 48ms 1 }

/* Source file https://github.com/MrOtherGuy/firefox-csshacks/tree/master/chrome/tabs_on_bottom_menubar_on_top_patch.css made available under Mozilla Public License v. 2.0
See the above repository for updates as well as full license text. */

/* Menubar on top patch - use with tabs_on_bottom.css */
/* Only really useful if menubar is ALWAYS visible */

:root{ --uc-window-control-width: 0px !important }

#navigator-toolbox{ padding-top: calc(29px + var(--uc-titlebar-padding,0px)) !important }

#toolbar-menubar{
position: fixed;
display: flex;
top: var(--uc-titlebar-padding,0px);
height: 29px;
width: 100%;
overflow: hidden;
}

#toolbar-menubar > .titlebar-buttonbox-container{ height: 29px; order: 100; }

#toolbar-menubar > [flex]{ flex-grow: 100; }
#toolbar-menubar > spacer[flex]{
order: 99;
flex-grow: 1;
min-width: var(--uc-window-drag-space-width,20px);
}

#toolbar-menubar .titlebar-button{ padding: 2px 17px !important; }

#toolbar-menubar .toolbarbutton-1 { --toolbarbutton-inner-padding: 3px }

/* TABS: height */
*|*:root {--tab-toolbar-navbar-overlap: 0px !important; --tab-min-height: 25px !important;  --tab-min-width: 80px !important;}

#tabbrowser-tabs {
width: 100vw !important;
}
#main-window:not([chromehidden*="toolbar"]) #navigator-toolbox {padding-bottom: var(--tab-min-height) !important;}

.tab-background {
border-radius: 8px 8px 0px 0px !important; border-image: none !important;
}
.tab-line {
display: none;
}

.tab-close-button {
color: red!important;
}

This is what I have found. Will this fix my problem?

Thank you,

Anne

由 cor-el 於 修改

有幫助嗎?

more options

Hi Anne, you can try it and see how it works. I can't restart Firefox right now to test.

有幫助嗎?

more options

Sorry to be a pest, but I don't know how to put this in the chrome folder. I don't even know where the chrome folder is located.

有幫助嗎?

more options

有幫助嗎?

more options

I have gone in and created a chrome folder, but the tabs are still on top, but I am closer. If I can ever get this fixed, I am going to create numerous backups so I don't have to go through this aggravation.

有幫助嗎?

more options

Note that the code for userChrome.css you posted is missing some closing brackets. I've edited the code in your reply to fix this, but haven't test the code.

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

有幫助嗎?

more options

Ok, I have gone in and created the folder. I cut and paste the previous Old Firefox data I had. That did not work. The tabs are still on top. My husband's profile is working fine. We currently have three profiles on Firefox, Anne, default, and Bill. Since my husbands is working, would it be possible to simply copy his "chrome", and paste it in my folder.

I am sorry to continue bothering you, but on good point is that I seem to be learning, or at least remembering some things.

Anne

有幫助嗎?

more options

有幫助嗎?

more options

Jefferson, I just did as you suggested, and it did not work. I am now completely confused and disheartened. Even my husband is at a loss as to how to put my tabs back on bottom. Why won't Firefox just fix it so we can easily customize Firefox the way we want it to be?

有幫助嗎?

more options

I got up and logged onto the Internet this morning, and my tabs are now back on the bottom. I do not know what I did, if anything, but it seems to be fixed. Now I have to re-add my add-ons. Everything else seems to be fine. I wish there was something I could do to repay your kindness and your being so helpful.

Thank you,

Anne

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題