搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

I want to disable Ctrl+H keyboard shortcut (toggles History sidebar)

  • 6 回覆
  • 0 有這個問題
  • 36 次檢視
  • 最近回覆由 smartsage77

more options

On my Firefox (in Linux, at least), doing Ctrl+H toggles the History sidebar (opening it on the left side, or, hiding the sidebar completely).

How can I disable this?

Firefox 104.0.2 Linux Mint 20.3

On my Firefox (in Linux, at least), doing Ctrl+H toggles the History sidebar (opening it on the left side, or, hiding the sidebar completely). How can I disable this? Firefox 104.0.2 Linux Mint 20.3

所有回覆 (6)

more options

Firefox does not have a built-in feature to disable keyboard shortcuts (with very rare exceptions).

Is the problem that a page that uses Ctrl+H isn't working as expected?

If you just want Ctrl+H to do nothing, maybe one of these add-ons can do it (I don't use these myself):

有幫助嗎?

more options

jscher2000 - Support Volunteer said

Is the problem that a page that uses Ctrl+H isn't working as expected?

Oh, it is working as expected. But every time I hit Ctrl + H is accidental. :) In other words, I don't intend to do Ctrl+H.


jscher2000 - Support Volunteer said

If you just want Ctrl+H to do nothing, maybe one of these add-ons can do it (I don't use these myself):

I guess I could install another extension, but I try to be minimal in my use of addons, especially if tweaking some file in the Firefox code would do the job. :)

有幫助嗎?

more options

If you are into advanced hacking, a startup script can remap keyboard shortcuts. I have a general page on that, but r/FirefoxCSS would be a good place to get a specific recommendation:

有幫助嗎?

more options

This is about the key command with ID "key_gotoHistory".

See this thread for code you can use with autoconfig.js and autoconfig.cfg.

有幫助嗎?

more options

cor-el said

See this thread for code you can use with autoconfig.js and autoconfig.cfg.


Dear cor-el, I found your reply in this "key binds" post that mentions autoconfig.js and autoconfig.cfg: https://support.mozilla.org/en-US/questions/1376993#answer-1505522

由 Mozilla cheese 於 修改

有幫助嗎?

more options

petergroft said

Steps to disable or enable Ctrl key shortcuts in CMD on Windows 10:

I'm on Linux. :)

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題