搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Mailto missing

  • 5 回覆
  • 5 有這個問題
  • 82 次檢視
  • 最近回覆由 AliceWyman

more options

Mailto is missing from my applications section in Firefox settings. How do I add it back in? I've done an online search but nothing I found worked.

I'm having difficulties adding an image but this is what is listed in my Settings - General - Applications: Under Content Type, I have: Portable Document Format (PDF) Extensible Markup Language (XML) Scalable Vector Graphics (SVG) WebP Image AV1 Image File (AVIF)

I tried searching applications for mailto and gmail but I get no returns.

Does anyone have any suggestions?

Mailto is missing from my applications section in Firefox settings. How do I add it back in? I've done an online search but nothing I found worked. I'm having difficulties adding an image but this is what is listed in my Settings - General - Applications: Under Content Type, I have: Portable Document Format (PDF) Extensible Markup Language (XML) Scalable Vector Graphics (SVG) WebP Image AV1 Image File (AVIF) I tried searching applications for mailto and gmail but I get no returns. Does anyone have any suggestions?

被選擇的解決方法

Another possibility is using the Profile Manager to create a new profile and copy the handlers.json file in the new profile to your current profile. It is not intended to keep using the new profile, its only purpose is to get its default handlers.json file and use that in your current profile. You can remove this profile or keep it for future use or for testing.

See "Creating a profile":

從原來的回覆中察看解決方案 👍 2

所有回覆 (5)

more options

This will reset the Applications handler to its default.

Enter about:support in the address bar and press Enter. Under Application Basics you will see Profile Folder. Click the button Open Folder. Close Firefox. In the Profile Folder, scroll down to handlers.json Cut the file and paste it somewhere temporarily (desktop) or rename it to handlers.json.old (don't delete it, yet) Close the Profile Folder and launch Firefox. Check your Applications section in Firefox settings.

more options

If Firefox still doesn't include the GMail mailto and you are a trusting person (or able to read the handlers.json file in a Firefox tab and confirm that it's safe), I have a substitute file you can download from here:

https://www.jeffersonscher.com/res/legacy-handlers.zip

more options

選擇的解決方法

Another possibility is using the Profile Manager to create a new profile and copy the handlers.json file in the new profile to your current profile. It is not intended to keep using the new profile, its only purpose is to get its default handlers.json file and use that in your current profile. You can remove this profile or keep it for future use or for testing.

See "Creating a profile":

more options

Thank you, Cor-el!

Using the Refresh Firefox method worked! I now have the mailto field and have added Gmail as my preferred email. I tested it and it is working so far. Thank you!

more options

Thanks for letting us know that the Refresh Firefox method fixed the problem. That's the solution suggested in the Change the program used to open email links article (quote):

Note: If the mailto Content Type is missing, or if action items such as Use Gmail are missing, a Firefox Refresh will restore all Content Types and actions to default settings. However, this will remove all customizations, including settings for other content types. See Refresh Firefox - reset add-ons and settings and Manage file types and download actions in Firefox for more information.

Creating a new profile, copying the handlers.json file from the new to your current profile, and then removing the new profile or setting your current profile as the default would also work but it's more complicated. The advantage with the new profile method is that it only resets Content Types and actions to default settings; it keeps the add-ons and other customizations that are removed with a Refresh.

由 AliceWyman 於 修改