搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

No longer shown warning screen with advanced button for self signed certs

  • 1 回覆
  • 0 有這個問題
  • 11 次檢視
  • 最近回覆由 cor-el

more options

Folks -

I am working with an internal development web site that uses self signed certificates for https / ssl.

Previously when browsing to this site, FF would present me with a web page that said "Warning: Potential Security Threat Ahead", but then also present an "Advanced" button on this page that would allow me to choose to ignore the cert error and proceed to the site anyways.

Recently, I now no longer have the option to proceed to the site anyways. I might have upgraded my DD during that time. We've also generated new certs recently. FF now just shows an "Unable to Connect" error message and there is no "Advanced" button or option to bypass the cert error and proceed to the site. This is on Firefox 91.12.0esr.

FWIW, both Chrome and IE still present me with options to bypass the cert error and proceed to the site.

Possibly FF will allow you to bypass an invalid CA, but not an invalid CN ?

Folks - I am working with an internal development web site that uses self signed certificates for https / ssl. Previously when browsing to this site, FF would present me with a web page that said "Warning: Potential Security Threat Ahead", but then also present an "Advanced" button on this page that would allow me to choose to ignore the cert error and proceed to the site anyways. Recently, I now no longer have the option to proceed to the site anyways. I might have upgraded my DD during that time. We've also generated new certs recently. FF now just shows an "Unable to Connect" error message and there is no "Advanced" button or option to bypass the cert error and proceed to the site. This is on Firefox 91.12.0esr. FWIW, both Chrome and IE still present me with options to bypass the cert error and proceed to the site. Possibly FF will allow you to bypass an invalid CA, but not an invalid CN ?
附加的畫面擷圖

所有回覆 (1)

more options

Do you have older exceptions for those certificates?

Try to rename the cert9.db file (cert9OLD.db) and remove a possible previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can possibly try the next 102 ESR version (Firefox 102.1.0esr) as Firefox 91 ESR is almost EOL to see whether it behaves differently. Use the version selector (Which version would you like?):

Make sure to create a new profile.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題