搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

firefox switching to tab with login prompt everytime on startup

  • 5 回覆
  • 0 有這個問題
  • 19 次檢視
  • 最近回覆由 kushagraR

more options

everytime I open firefox, it automatically switches tabs like these which require authentication to log in. even though their password is saved, I am still required to click in sign-in button.

Its really annoying that these kind of tabs get opened automatically, and then I have to switch back. Is there a way to disable this autoswitch or better, let the authentication happen automatically since the password is already stored ?

everytime I open firefox, it automatically switches tabs like these which require authentication to log in. even though their password is saved, I am still required to click in sign-in button. Its really annoying that these kind of tabs get opened automatically, and then I have to switch back. Is there a way to disable this autoswitch or better, let the authentication happen automatically since the password is already stored ?
附加的畫面擷圖

被選擇的解決方法

Firefox comes with two on_demand prefs that determine the behavior on startup. By default pinned tabs are always restored and normal tabs are restored on demand, i.e. if you select them. You can set both prefs to true to open all tabs only when you select them. This also makes startup faster if you have a lot of pinned tabs.

  • browser.sessionstore.restore_on_demand = true
  • browser.sessionstore.restore_pinned_tabs_on_demand = true

You can open the about:config page via the location/address bar. If you get the warning page, you can click the "Accept the Risk and Continue" button.

從原來的回覆中察看解決方案 👍 2

所有回覆 (5)

more options

That's not from firefox. You need to change it back to default firefox install page or set a homepage that isn't a login.

有幫助嗎?

more options

yes, this seems to a specific type of dropdown login box which some sites ask before being allowed access to it. I normally see in login pages of routers and here for transmission as well which is running from a different server ( see image attached below ).

Whenver firefox is launched, it loads and focuses the last tab which was active before being closed last time. Then almost second later focus is switched from that tab to this old tab which requires authentication. which should not be desired behaviour imo

pls note that homepage is set to firefox default

有幫助嗎?

more options

That is coming from your tabs to the site your having it open when you open firefox browser. Either you set to save AutoSave Login or you don't open that til your Browser up and running. Or Bookmark it to open your ready.

有幫助嗎?

more options

選擇的解決方法

Firefox comes with two on_demand prefs that determine the behavior on startup. By default pinned tabs are always restored and normal tabs are restored on demand, i.e. if you select them. You can set both prefs to true to open all tabs only when you select them. This also makes startup faster if you have a lot of pinned tabs.

  • browser.sessionstore.restore_on_demand = true
  • browser.sessionstore.restore_pinned_tabs_on_demand = true

You can open the about:config page via the location/address bar. If you get the warning page, you can click the "Accept the Risk and Continue" button.

由 cor-el 於 修改

有幫助嗎?

more options

thanks this worked, above tab was infact a pinned tab so it was loading automatically at launch.

> browser.sessionstore.restore_pinned_tabs_on_demand = true

this did the trick

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題