搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Google Searches in Firefox Repeating Itself

  • 6 回覆
  • 0 有這個問題
  • 2 次檢視
  • 最近回覆由 urishino

more options

There is this weird bug(?) that popped up like within a day or so. When searching for some terms with Google in Firefox, the search result would repeat itself. For example, searching for terms like "ab", "abc", or "hgi" would result in two searches, but not "def". So let's say if I search for "ab" twice, I would get 4 search histories of "ab".

One curious thing I noticed is that if I already have a non-blank tab opened before the search, going back to it and then going forward to any search that would repeat itself would prompt it to produce two search histories again. The problem to this is that if there were other searches further up the tab's histories (I usually search for multiple things within the same tab), they would essentially be lost (I turned off search and form history) when the search repeated itself, since it would act like I made a new search of the same term.

I have updated the Firefox browser to the latest stable version 103.0.1, and the problem persists. I tried to replicate this on Chrome to no avail. It's irking me to no end, so any help is much appreciated.

There is this weird bug(?) that popped up like within a day or so. When searching for some terms with Google in Firefox, the search result would repeat itself. For example, searching for terms like "ab", "abc", or "hgi" would result in two searches, but not "def". So let's say if I search for "ab" twice, I would get 4 search histories of "ab". One curious thing I noticed is that if I already have a non-blank tab opened before the search, going back to it and then going forward to any search that would repeat itself would prompt it to produce two search histories again. The problem to this is that if there were other searches further up the tab's histories (I usually search for multiple things within the same tab), they would essentially be lost (I turned off search and form history) when the search repeated itself, since it would act like I made a new search of the same term. I have updated the Firefox browser to the latest stable version 103.0.1, and the problem persists. I tried to replicate this on Chrome to no avail. It's irking me to no end, so any help is much appreciated.
附加的畫面擷圖

所有回覆 (6)

more options

There isn't any way to capture the URLs from the Back button list, but you could try the Library window (Ctrl+Shift+H or "Show All History"). It should start off by listing today's history, usually in reverse chronological order.

My guess is that there is some difference in the parameters in Google's very long search string between the two history entries, but even in that list, the space might be too narrow, so you might need to right-click > Copy and then paste into a blank document somewhere to compare them.

I don't know whether you will find that: my theory is wrong, Google is changing something, or an add-on or other actor is changing something.

有幫助嗎?

more options

Hey @jscher2000, thanks for the fast reply! I checked the Library window, and the repeated searches weren't even registered.

有幫助嗎?

more options

Oh... that looks different than the internal "bookmark" in the page issue. (That's where news sites update the URL with a # referring to the story titles you scroll past.)

You might need to copy/paste from the address bar assuming that you can go back one entry at a time.

有幫助嗎?

more options

有幫助嗎?

more options

It's difficult to think of why an add-on might cause this, but just in case, you could test in Firefox's Troubleshoot Mode. In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any difference?

By the way, I think source=hp might mean that you submitted the current query from the search form on Google's home page (i.e., not related to Hewlett-Packard or other possible meanings).

有幫助嗎?

more options

Hey @jscher2000, I just tried and nope, similar things still happen. The URL is shorter due to Troubleshoot mode (https://www.google.com/search?client=firefox-b-d&q=ab), but that's it.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題