搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Image Size starting with Firefox 103

  • 16 回覆
  • 1 有這個問題
  • 334 次檢視
  • 最近回覆由 Paul

more options

The first image is with Fx 103 https://i.imgur.com/r9L3MtM.jpg

This next one is with Fx 102 https://i.imgur.com/N8p1gis.jpg

Others having resolutions other than 1920 x 1080 are having the same problem. Any help would be appreciated

The first image is with Fx 103 https://i.imgur.com/r9L3MtM.jpg This next one is with Fx 102 https://i.imgur.com/N8p1gis.jpg Others having resolutions other than 1920 x 1080 are having the same problem. Any help would be appreciated

由 cor-el 於 修改

被選擇的解決方法

From https://www.mozilla.org/en-US/firefox/103.0/releasenotes/ (quote) New | Windows' "Make text bigger" accessibility setting now affects all the UI and content pages, rather than just affecting system font sizes.

Here is the solution posted in another thread today, https://support.mozilla.org/en-US/questions/1384060

Windows' "Make text bigger" accessibility setting now affects all the UI and content pages, rather than only applying to system font sizes. To get stuff back to normal, reset Windows' "Make text bigger" setting to 100% or enter about:config in the URL bar and create a new number pref ui.textScaleFactor = 100.

The explanation for this issue and how to fix it can be found in this comment in the related bug report.

P.S. I don't use Windows 10 or Windows 11 so maybe someone else can help you further.

從原來的回覆中察看解決方案 👍 1

所有回覆 (16)

more options

I'm still on Firefox 102, but during the beta cycle of Firefox 103, a number of users reported that Firefox was now double-enlarging text. A new preference was just added to help control this, but I haven't experimented with it myself:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.display.os-zoom-behavior and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to 0 then press Enter or click the blue check mark button to save the change. How does that look?

Available values:

  • 0 => Ignore the OS-level scaling (historical behavior on Windows/Mac)
  • 1 => Apply OS-level scaling as proportional zoom [default] (historical behavior on Linux)
  • 2 => Apply OS-level scaling as text-only zoom

Beta Notes

A user posted a table on Reddit describing what is affected by these different values:

https://www.reddit.com/r/firefox/comments/vnpip6/deved_update_to_1030b2_just_made_everything_in/ie9zzoe/

Other References:

有幫助嗎?

more options

Thanks for your reply but this needs to be fixed by Mozilla. I hope. I have switched back to Fx 102.1ESR till this issue is resolved. Since this issue was first discovered in BETA 2, I have to question why it made it into the Final Release with only one RC????

有幫助嗎?

more options

選擇的解決方法

From https://www.mozilla.org/en-US/firefox/103.0/releasenotes/ (quote) New | Windows' "Make text bigger" accessibility setting now affects all the UI and content pages, rather than just affecting system font sizes.

Here is the solution posted in another thread today, https://support.mozilla.org/en-US/questions/1384060

Windows' "Make text bigger" accessibility setting now affects all the UI and content pages, rather than only applying to system font sizes. To get stuff back to normal, reset Windows' "Make text bigger" setting to 100% or enter about:config in the URL bar and create a new number pref ui.textScaleFactor = 100.

The explanation for this issue and how to fix it can be found in this comment in the related bug report.

P.S. I don't use Windows 10 or Windows 11 so maybe someone else can help you further.

由 AliceWyman 於 修改

有幫助嗎?

more options

When you say it needs to be fixed, do you mean the default setting should be changed to zero? Maybe that will happen; much too soon to tell as it doesn't seem to affect many users.

有幫助嗎?

more options

It should not be up to the end user to fix this. It affects more than you know. I will not try any hacks to fix this. I have been using Firefox from day one and at 74 Years of age and with a 32" Monitor, I am done with hacks. I reset Windows 11 to 100% and Firefox is still too big. I tried what was posted about the fix in the About:Config and since this was a known issue since BETA 2 , I have to wonder why? I guess Microsoft was right when they said Open Source is not good. I will use 102.1 ESR Build forever if I have to. This issue is not solved/

有幫助嗎?

more options

I don't have Windows 11 yet. Probably will get hands on in the new year. We'll see what happens. Obviously it's not up to me which settings get added to the "Appearance" section of the Settings page and which remains hidden in about:config.

有幫助嗎?

more options

Funny that it does not affect any other apps like Thunderbird . Trying to push the blame on Windows is just nuts. I would guess that wherever Mozilla has an office it is not handicapped accessible. BTW I am not, just wanted a 32 " Monitor although I did have cataract surgery .There is a user I know that has a 27" and he has the same issue. If you ever watch Jayz2cents on YouTube 32" monitors will be the norm with up to 300- 400 Hz so either get with the program or use Linux.

有幫助嗎?

more options

Well, my point was that since you aren't going to experiment with the setting I mentioned, and I don't have Windows 11 -- and also not shopping for a new monitor -- we'll just have to wait and see who else can test it out and confirm either that it works or that there's still a bug.

有幫助嗎?

more options

Windows' "Make text bigger" accessibility setting now affects all the UI and content pages, rather than only applying to system font sizes.

To get stuff back to normal, reset Windows' "Make text bigger" setting to 100% or enter about:config in the URL bar and create a new number pref ui.textScaleFactor = 100.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

Modified July 26, 2022 at 4:41:48 PM PDT by Chris Ilias The Fix is NOT Supported. So what would happen down the road if MS changes something else? Are trying to tell me that Mozilla does not have qualified coders that can fix this for all users permanently??

有幫助嗎?

more options

See also:

  • 1773823 - devPixelsPerPx scales system fonts too much on HiDPI
  • 1773633 - Everything too big after Bug 1773342

(please do not comment in bug reports
https://https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

有幫助嗎?

more options

Thanks for all of your help, I was sort of in a bad mood yesterday. I will try this fix of yours when I get a chance, I think I would only have to do this one time. Again Thank you.

有幫助嗎?

more options

Another suggestion going around involves creating a new preference. In case the above doesn't work, this is the next one to try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste ui.textScaleFactor and pause while the list is filtered.

Normally, Firefox will display a bar with Boolean Number String and a plus button. If Firefox displays a row that already has a number value, skip to step 5.

(3) Click the circular button in front of Number and then click the + button to create a new preference. (See composite screenshot below.)

(4) Firefox should display an editing field, and show a value of 0 -- edit the value to 100 then press Enter or click the blue check mark button to save the change.

(5) If the current value of ui.textScaleFactor is NOT 100, then double-click the preference to display an editing field, and change the value to 100 then press Enter or click the blue check mark button to save the change.

有幫助嗎?

more options

Yes this all worked except the text in the Tabs and in any Context menu. I am back on The ESR till this can be fixed by Mozilla or Microsoft as I have had enough of it. The fix you guys showed worked about 95% , I need 100%.

有幫助嗎?

more options

Gary77 said

Yes this all worked except the text in the Tabs and in any Context menu.

Was it still too big, or did it become too small?

有幫助嗎?

more options

Way too small

有幫助嗎?

more options

Hi

While there is not an easy way to revert this our product team did suggest this about:config preference change as the optimal solution at this time.

  1. In the address bar, type about:config and press the Enter key.
  2. The about:config warning page may appear. Click Accept the Risk and Continue to continue to the about:config page.
  3. In the search field, enter browser.display.os-zoom-behavior, select the pencil "edit" icon and change the number to 0.
  4. Select the check mark and restart Firefox.

They did note they would look into alternative options which may be present in a future update.

WARNING from the moderator team: Changing Firefox pref from the about:config page can sometimes break Firefox or cause strange behavior. You should only do this if you know what you're doing.

Please read Firefox advanced customization and configuration options to learn more.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題