搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Cannot set cookie preferences when using Firefox

  • 8 回覆
  • 0 有這個問題
  • 16 次檢視
  • 最近回覆由 Sue

more options

Hi:

I tried to set cookie preferences for different websites. For reasons that I do not understand, I cannot move the "slider". I even turned of the existing protection for the websites, but nothing changed. I tried the same with Safari using the same computer and mouse, and I had no problems.

Is this a known bug?

I attached a screen capture. Thanks.

Hi: I tried to set cookie preferences for different websites. For reasons that I do not understand, I cannot move the "slider". I even turned of the existing protection for the websites, but nothing changed. I tried the same with Safari using the same computer and mouse, and I had no problems. Is this a known bug? I attached a screen capture. Thanks.

被選擇的解決方法

No problem with with toggling the slider by left-clicking on the slider. Do you get a special hand mouse pointer if you hover a slider ?


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
從原來的回覆中察看解決方案 👍 0

所有回覆 (8)

more options

有幫助嗎?

more options

Thanks, but do not understand your reply. I did attach a screen capture.

I cannot MOVE the slider to disable certain cookies when using Firefox.

有幫助嗎?

more options

The screenshot didn't attach.

Could you please give it another try to attach a screenshot?


Is this about cookie settings in "Settings -> Privacy & Security" or about the slider for Enhanced Tracking Protection that you see if you click the shield in the location bar ?

有幫助嗎?

more options

Thanks, cor-el. These are the sliders in the Privacy Preference Center. They do not slide in Firefox but they do slide in Safari. I am attaching again a screen capture. It does show in this "message" under Uploaded images the file.

有幫助嗎?

more options

That panel is part of the website itself, not a Firefox feature. This could be a problem like the script not being compatible with Firefox, or interference by an add-on.

I think you are familiar with the usual things we suggest for parts of web pages not working properly. However, it could be useful if you share a sample URL of a page that uses this privacy center overlay so support volunteers could take a look.

Note: please add a space before the top level domain when you paste a URL to bypass the link spam moderation queue. For example:

https://www.example .com/path/page

有幫助嗎?

more options

Thanks, jscher2000. The website (one of them) where this happens when using Firefox is: https://www.phonakpro. com/us/en/home.html

After going to this website, I picked Cookies Setting and that's where one can use the Privacy Preference Center.

I attached one more screen capture showing the pop-up for Cookies Setting.

有幫助嗎?

more options

選擇的解決方法

No problem with with toggling the slider by left-clicking on the slider. Do you get a special hand mouse pointer if you hover a slider ?


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

有幫助嗎?

more options

Thanks, cor-el.

I am embarrassed. I kept trying to drag the slider like in Safari. Left clicking worked. You solved the "problem". I apologize for wasting people's time, but sometimes the obvious is not obvious to everyone... I am glad I don't have to try to execute the rest, but I will keep the suggested options for a next time.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題