On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Why does Firefox put www in front of the domain name?

more options

When I type my website in the bar, firefox puts www in front of it, which causes the warning page: firefox detected a potential security threat and did not continue to www.karinchappell.com. If you visit this site, attackers could try to steal information like your passwords, emails, or credit card details.

If I remove the www by backspacing it, the page loads correctly.

I've checked the website: "SSL is enabled on your site, and an SSL certificate was detected on your site."

When I've asked around the techies I know, I've been told this is an antiquated way of dealing with it. Please advise.

When I type my website in the bar, firefox puts www in front of it, which causes the warning page: firefox detected a potential security threat and did not continue to www.karinchappell.com. If you visit this site, attackers could try to steal information like your passwords, emails, or credit card details. If I remove the www by backspacing it, the page loads correctly. I've checked the website: "SSL is enabled on your site, and an SSL certificate was detected on your site." When I've asked around the techies I know, I've been told this is an antiquated way of dealing with it. Please advise.

所有回覆 (1)

more options

Hmm, how did you get to that screen? If I start with

http://karinchappell.com/

after a couple seconds it redirects to:

https://karinchappell.com/

If I start with the URL on your Bio page

http://www.karinchappell.com/

it redirects to

https://karinchappell.com/

So far, so good.

If I turn on Firefox's HTTPS-Only feature, then instead of checking whether the www site will redirect, Firefox shows the HTTPS-Only Mode Alert screen. It sounds like you are not getting that screen. (More info on that feature in this article: HTTPS-Only Mode in Firefox.)

So if your Firefox is using an entry from history, there shouldn't be a problem. I'm not sure why Firefox thinks it should combine the https and the www. ??

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題