搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

YouTube not remembering selected resolution after Firefox refresh

  • 2 回覆
  • 1 有這個問題
  • 6 次檢視
  • 最近回覆由 Márk

more options

Lately I refreshed Firefox so I can boost it's performance cause it was running just a little bit slower than usual. Since than YouTube does not remember my selected resolution. Every time I close the tab, in the new tab it will have a much worse resolution and I did not have a problem until now. I am a system administrator and I'm currently learning programming as well, so I tried a lot of things to try to overcome this problem. The only extensions I have is Bitwarden, uBlock Origin, Cookie AutoDelete. And yes, youtube.com and *.google.com IS added to cookie AutoDelete. But even without it it's not working.

I have provided the Troubleshooting Information from about:support: Click Here for Troubleshooting Info

I also know that there are extensions like YouTube HD or Enhancer for YouTube what would solve this problem, but I would like to keep my extensions as minimal as possible.

Thank you!

Lately I refreshed Firefox so I can boost it's performance cause it was running just a little bit slower than usual. Since than YouTube does not remember my selected resolution. Every time I close the tab, in the new tab it will have a much worse resolution and I did not have a problem until now. I am a system administrator and I'm currently learning programming as well, so I tried a lot of things to try to overcome this problem. The only extensions I have is Bitwarden, uBlock Origin, Cookie AutoDelete. And yes, youtube.com and *.google.com IS added to cookie AutoDelete. But even without it it's not working. I have provided the Troubleshooting Information from about:support: [https://mega.nz/file/yQA2FaTa#aMAeOYDs2qNJztbYxiOfqNvoPxo-ii6MVoQDtf1AklM Click Here for Troubleshooting Info] I also know that there are extensions like YouTube HD or Enhancer for YouTube what would solve this problem, but I would like to keep my extensions as minimal as possible. '''Thank you!'''

由 Márk 於 修改

被選擇的解決方法

cor-el said

You can use these steps to make a website recognize and remember you.
  • create a cookie allow exception with the proper protocol (https:// or http://) to make a website remember you
You can check that you aren't clearing important cookies.
  • using "Delete cookies and site data when Firefox is closed" keeps cookies with an allow exception
  • using "Clear history when Firefox closes" to clear cookies clears all cookies including cookies with an allow exception you may want to keep
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions"
  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [X] "Clear history when Firefox closes" -> Settings

Thank you for your answer. I have found the problem. In Cookie AutoDelete there is an option called "Other Browsing Data Cleanup Options". I had to disable every one of those options. I tough it didn't matter because YouTube was already an exclusion for all of them.

從原來的回覆中察看解決方案 👍 0

所有回覆 (2)

more options

You can use these steps to make a website recognize and remember you.

  • create a cookie allow exception with the proper protocol (https:// or http://) to make a website remember you

You can check that you aren't clearing important cookies.

  • using "Delete cookies and site data when Firefox is closed" keeps cookies with an allow exception
  • using "Clear history when Firefox closes" to clear cookies clears all cookies including cookies with an allow exception you may want to keep
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions"
  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [X] "Clear history when Firefox closes" -> Settings

有幫助嗎?

more options

選擇的解決方法

cor-el said

You can use these steps to make a website recognize and remember you.
  • create a cookie allow exception with the proper protocol (https:// or http://) to make a website remember you
You can check that you aren't clearing important cookies.
  • using "Delete cookies and site data when Firefox is closed" keeps cookies with an allow exception
  • using "Clear history when Firefox closes" to clear cookies clears all cookies including cookies with an allow exception you may want to keep
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions"
  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [X] "Clear history when Firefox closes" -> Settings

Thank you for your answer. I have found the problem. In Cookie AutoDelete there is an option called "Other Browsing Data Cleanup Options". I had to disable every one of those options. I tough it didn't matter because YouTube was already an exclusion for all of them.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題