搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Spacebar not working on random sites

more options

Clicking on the spacebar, does not produce a space between words, when typing text. I'm using a Mac Mini M1, on macOS Monterey (V 12.4), along with a Logitech MX Keys for Mac keyboard.

This happens randomly, for instance, on this very message. I previously posted a question regarding another problem that I came across with the same hardware and Firefox.

I found the solution to that problem by disabling an Extension in Firefox, however, I can't begin to think where to look for what setting, that may be causing my current problem.

Clicking on the spacebar, does not produce a space between words, when typing text. I'm using a Mac Mini M1, on macOS Monterey (V 12.4), along with a Logitech MX Keys for Mac keyboard. This happens randomly, for instance, on this very message. I previously posted a question regarding another problem that I came across with the same hardware and Firefox. I found the solution to that problem by disabling an Extension in Firefox, however, I can't begin to think where to look for what setting, that may be causing my current problem.

被選擇的解決方法

Well, it seems I've found the culprit, for now...

I went to macOS settings for the keyboard, not the actual settings for the hardware.

In macOS>Keyboard, select the "Shortcut" tab and scroll down to "Keyboard", select it. On the right, a display of shortcuts is shown.

At the very top, I had "Change the way Tab moves focus" checked. I unchecked it and the problem disappeared.

Crossing my fingers and hoping this is the solution.

從原來的回覆中察看解決方案 👍 0

所有回覆 (1)

more options

選擇的解決方法

Well, it seems I've found the culprit, for now...

I went to macOS settings for the keyboard, not the actual settings for the hardware.

In macOS>Keyboard, select the "Shortcut" tab and scroll down to "Keyboard", select it. On the right, a display of shortcuts is shown.

At the very top, I had "Change the way Tab moves focus" checked. I unchecked it and the problem disappeared.

Crossing my fingers and hoping this is the solution.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題