搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Desktop URLs not working today, Firefox as default browser -- but work if default browser toggled to Edge

  • 3 回覆
  • 1 有這個問題
  • 1 次檢視
  • 最近回覆由 jonzn4SUSE

more options

Hi folks,

I've asked this same question of Microsoft, as I cannot tell if this is a quirk in Firefox 100.0.2, or in Windows 10 Home, or something to do with what they put in the water here (besides flouride)...

Over the last few days I've had to reinstall Office on this Windows 10 Home system, and had a Firefox update to 100.0.2 as well. Everything working fine up through last night -- URL shortcuts on the desktop would open Firefox (default browser) just fine.

Shut down. Cold boot this morning. Manually open Firefox as usual. Double-click on desktop URL shortcuts (or right-click, Open) gets a real quick hourglass and then nothing. No error, no browser tab.

So I checked: default browser still set to Firefox; .URL filetype still set to "Internet Browser."

I toggled the default browser to Edge, and the links work just fine. Same links. No changes to them.

Toggle it back to the much more privacy-protecting Firefox and... they won't work.

This seems spooky.

Note that the desktop icons for these shortcuts correctly show either the Firefox icon, or the logo/icon for the web page itself (ie, Google Maps). And the toggle of default browser did NOT update the icons.

Any ideas?

Thanks!

Hi folks, I've asked this same question of Microsoft, as I cannot tell if this is a quirk in Firefox 100.0.2, or in Windows 10 Home, or something to do with what they put in the water here (besides flouride)... Over the last few days I've had to reinstall Office on this Windows 10 Home system, and had a Firefox update to 100.0.2 as well. Everything working fine up through last night -- URL shortcuts on the desktop would open Firefox (default browser) just fine. Shut down. Cold boot this morning. Manually open Firefox as usual. Double-click on desktop URL shortcuts (or right-click, Open) gets a real quick hourglass and then nothing. No error, no browser tab. So I checked: default browser still set to Firefox; .URL filetype still set to "Internet Browser." I toggled the default browser to Edge, and the links work just fine. Same links. No changes to them. Toggle it back to the much more privacy-protecting Firefox and... they won't work. This seems spooky. Note that the desktop icons for these shortcuts correctly show either the Firefox icon, or the logo/icon for the web page itself (ie, Google Maps). And the toggle of default browser did NOT update the icons. Any ideas? Thanks!

所有回覆 (3)

more options

Not able to replicate the issue. I put a shortcut on my desktop and it opened a new tab. see screenshot. Where did you get Firefox from? Sorry about the arrows... it looks good in my screenshot, not sure what happened, but you get the idea.  ;-)

https://paste.opensuse.org/43625190

由 jonzn4SUSE 於 修改

有幫助嗎?

more options

Jon, thanks for the comments. About three hours after I posted this, Windows complained that it was finding errors on my disk drive (an NTFS volume); after it repaired those and rebooted, all was behaving normally.

Go figure.

有幫助嗎?

more options

Glad to hear your issue is resolved. Mark this issue as resolved routinely run chkdsk and defrag. ;-)

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題