搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Unsubscribed folders still showing in folder list

  • 11 回覆
  • 2 有這個問題
  • 38 次檢視
  • 最近回覆由 Matt

more options

Hello,

I'm using Thunderbird 91.9.0 (32-bit) on Windows 7. It's connected to a Gmail account via IMAP. The account contains dozens of message folders. I want to hide some of those folders from the list of folders.

I tried unsubscribing from those folders. In the panel on left, I right-click my account name and select "Subscribe". The window that subsequently pops up shows all of my folders, and all of the checkboxes next to each folder are checked. I remove the checkmarks from each of the folders that I want to hide, and I click OK at the bottom.

However, after doing this, the folders still appear in my folder list.

When I reopen the Subscribe window, I see that the checkmarks for those folder are still removed. But the folders still appear in my folder list. Closing and restarting Thunderbird does not help.

Evidently, the Subscribe window does not function as I would expect it to. How can I make those folders go away without deleting them or removing them from Gmail's servers?

Thank you.

Hello, I'm using Thunderbird 91.9.0 (32-bit) on Windows 7. It's connected to a Gmail account via IMAP. The account contains dozens of message folders. I want to hide some of those folders from the list of folders. I tried unsubscribing from those folders. In the panel on left, I right-click my account name and select "Subscribe". The window that subsequently pops up shows all of my folders, and all of the checkboxes next to each folder are checked. I remove the checkmarks from each of the folders that I want to hide, and I click OK at the bottom. However, after doing this, the folders still appear in my folder list. When I reopen the Subscribe window, I see that the checkmarks for those folder are still removed. But the folders still appear in my folder list. Closing and restarting Thunderbird does not help. Evidently, the Subscribe window does not function as I would expect it to. How can I make those folders go away without deleting them or removing them from Gmail's servers? Thank you.

被選擇的解決方法

Please check the following:

  • Right click on imap mail account name in Folder Pane and select 'Settings'
  • Click on 'Server Settings'
  • click on 'Advanced...' button
  • Select checkbox 'Show only subscribed folders'
  • Click on 'OK'

Exit Thunderbird and wait a few moments for background processes to complete.

Start Thunderbird

Please Report back on results.

從原來的回覆中察看解決方案 👍 2

所有回覆 (11)

more options

Log into gmail website and specify there not to show on email clients.

有幫助嗎?

more options

david said

Log into gmail website and specify there not to show on email clients.

Thank you for your response.

But is the only solution to make changes on Gmail's side? What is the point of the unsubscribe feature in Thunderbird if it doesn't hide the folders?

有幫助嗎?

more options

try restarting Thunderbird. My understanding is there is a bug that caused oauth authenticated account to not update the folder pane until a restart. 91.9 changed all Gmail accounts to oath.

有幫助嗎?

more options

Matt said

try restarting Thunderbird. My understanding is there is a bug that caused oauth authenticated account to not update the folder pane until a restart. 91.9 changed all Gmail accounts to oath.

Thank you for your response.

As I mentioned in my original question, closing and restarting Thunderbird did not help.

有幫助嗎?

more options

選擇的解決方法

Please check the following:

  • Right click on imap mail account name in Folder Pane and select 'Settings'
  • Click on 'Server Settings'
  • click on 'Advanced...' button
  • Select checkbox 'Show only subscribed folders'
  • Click on 'OK'

Exit Thunderbird and wait a few moments for background processes to complete.

Start Thunderbird

Please Report back on results.

有幫助嗎?

more options

I had this same issue with a domain that I own.

In my case, SpamAssassin runs on the server and insists on using a folder named "spam". But a folder named "Junk" appears in Thunderbird. Whether I delete that folder on the server or in Thunderbird, it always gets recreated when I restart the latter (no matter how I configure junk settings in Thunderbird, mind).

The instructions in the post immediately above to enable the "Show only subscribed folders" setting resolved this for me. Thank you very much.

由 valid_username 於 修改

有幫助嗎?

more options

And yet you still have not actually fixed the issue. Why not go into the account settings > Junk Settings and set the spam folder as the one used for the junk process. Then you can delete the Junk folder and because Thunderbird will not be using it anymore it will not be recreated.

有幫助嗎?

more options

Matt said

And yet you still have not actually fixed the issue. Why not go into the account settings > Junk Settings and set the spam folder as the one used for the junk process. Then you can delete the Junk folder and because Thunderbird will not be using it anymore it will not be recreated.

I've in fact done that. Tried many times. The "Junk" folder gets recreated for reasons I can't discern. Absolutely nothing in the Thunderbird UI explicitly points to it and yet it gets created.

有幫助嗎?

more options

To valid_username

re: no matter how I configure junk settings in Thunderbird,

There is only one setting you should use.

  • In Account Settings > Junk Settings for account.
  • Select 'Move new junk messages to;
  • Select 'Other' and choose 'Spam on account name'

If at some point you selected the 'Junk' folder, then it may get created. At this point it would also get put on server. Not sure what is going on, but this is the course of action I would try in order stated.

  • Set Account Settings correctly so 'Other' and 'Spam' is selected.
  • Unsubscribe from seeing 'Junk' because at this point it exists on server.
  • Delete 'Junk'
  • Empty 'Trash'
  • Compact all folders just in case something has a junk flag set.
  • Check 'Message Filters' - is there anything being sent to a 'Junk' folder - if yes then modify to go to 'spam'.

Exit Thunderbird.

  • Access 'profile name' folder
  • click on 'ImapMail' folder
  • Click on mail account name folder.
  • Check to see if the is any file or folder called 'Junk'.
  • eg: 'Junk' (no extension mbox file), 'Junk.msf' index file or 'Junk.sbd' folder
  • Delete any that exist.
  • Access webmail and check 'Junk' does not exist - delete if it exists.

Start Thunderbird.

由 Toad-Hall 於 修改

有幫助嗎?

more options

Toad-Hall said

Please check the following:
  • Right click on imap mail account name in Folder Pane and select 'Settings'
  • Click on 'Server Settings'
  • click on 'Advanced...' button
  • Select checkbox 'Show only subscribed folders'
  • Click on 'OK'
Exit Thunderbird and wait a few moments for background processes to complete. Start Thunderbird Please Report back on results.

Hello,

I followed your directions to find the setting for "show only subscribed folders". This setting was already enabled (checked).

However, I figured I might as well mess with it and see what happens. I disabled the setting and clicked OK. Shortly afterward, I re-enabled the setting and clicked OK. Then I restarted Thunderbird. What do you know... It worked. All of my unsubscribed folders are finally hidden.

This doesn't seem to me like expected behavior. Perhaps a bug in Thunderbird that needs fixing?

Thanks very much for helping me find the solution.

有幫助嗎?

more options

There is a bug that results in folders not updating until Thunderbird restarts. When the authentication method is set to oAUth. Which has just becomes the case with all Gmail accounts.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題