搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How to get rid of leftover separators in bookmark menu?

  • 4 回覆
  • 1 有這個問題
  • 9 次檢視
  • 最近回覆由 cor-el

more options

I removed everything from the bookmarks menu that I don't need. Now there is a battery of separators left, consuming menu space. See attached screenshot of German Firefox version.

How to get rid of at least four of those five separators?

Also, it would be great to have all my bookmarks at the top of the menu, while all that stuff I rarely need (Show bookmark sidebar, More bookmarks, Bookmars symbol bar ...) is at the bottom. Is there an way to change that?

I removed everything from the bookmarks menu that I don't need. Now there is a battery of separators left, consuming menu space. See attached screenshot of German Firefox version. How to get rid of at least four of those five separators? Also, it would be great to have all my bookmarks at the top of the menu, while all that stuff I rarely need (Show bookmark sidebar, More bookmarks, Bookmars symbol bar ...) is at the bottom. Is there an way to change that?
附加的畫面擷圖

被選擇的解決方法

Quote: I removed everything from the bookmarks menu that I don't need.

How did you remove those items (did you use code in userChrome.css) ? Do you also see these separators in the bookmarks sidebar or in the Library ?

從原來的回覆中察看解決方案 👍 1

所有回覆 (4)

more options

Note that these separators were not inserted by me but by Firefox; they separated those predefined submenus that I removed via right-click->delete. When I right click onto these separators, there is no deletion option.

有幫助嗎?

more options

選擇的解決方法

Quote: I removed everything from the bookmarks menu that I don't need.

How did you remove those items (did you use code in userChrome.css) ? Do you also see these separators in the bookmarks sidebar or in the Library ?

有幫助嗎?

more options

cor-el said

Quote: I removed everything from the bookmarks menu that I don't need. How did you remove those items (did you use code in userChrome.css) ? Do you also see these separators in the bookmarks sidebar or in the Library ?

I removed them by right-clicking onto them and chosing "Löschen" (Delete).

And yes, four of those five separators are also visible in the bookmarks sidebar. And when I click onto them there, there is a delete option. And it works, and now they are all gone. Thanks!

Did some further tests now with adding and deleting separators. When I right-click onto a separator in the bookmarks menu, sometimes there is delete option, but often not. Pretty random, I tried multiple times with the same separator, suddenly there is a delete option, and with next right-click it is gone. This is some bug. But for me the issue is solved by using the sidebar instead.

有幫助嗎?

more options

It is not easy to click on a separator in a menu drop-down list or on the Bookmarks Toolbar as you need to position the cursor quite precise. It is much easier to do this in the sidebar and in the Bookmarks Manager (Library).

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題