搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox keeps disabling addons

  • 9 回覆
  • 1 有這個問題
  • 22 次檢視
  • 最近回覆由 Dropa

more options

Firefox keeps disabling addons randomly, some of them are made by mozilla even. I am getting them from the official addon site so they shouldn't be illegitimate ones. Let me know what information about my install I can give to help.


OS version: windows 22000.593 Firefox version: 99.0.1 (64-bit)

Firefox keeps disabling addons randomly, some of them are made by mozilla even. I am getting them from the official addon site so they shouldn't be illegitimate ones. Let me know what information about my install I can give to help. OS version: windows 22000.593 Firefox version: 99.0.1 (64-bit)
附加的畫面擷圖

所有回覆 (9)

more options

Did you remove each Addon and reinstall them to see what happens.

有幫助嗎?

more options

donthavecow said

Did you remove each Addon and reinstall them to see what happens.

I have not done it with all of these ones however I have done two of them previously and when I removed them then added them back they were enabled and functioned normally. After about 2 days one of them got disabled in the same way again but the other was still working. Having this many disabled has just happened and is why I finally decided to see if I could get a solution for this because before the most that were disabled was two.

有幫助嗎?

more options

What did the developers of each of those apps say about this happening.

有幫助嗎?

more options

I've only sent a message to one of the developers but have yet to receive a reply. The one addon is made by mozilla/firefox themselves though.

I can't imagine this is something that is a problem with the addons unless there was a change in firefox recently that would do this.

有幫助嗎?

more options

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address box and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show/Open Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files"

+++++++++++++++++++++++++++ You may have to approve the updating once again.

有幫助嗎?

more options

After removing those files from my profile the addons are no longer disabled. I will give it a few days to see if they get disabled again or if this solved the problem. Will get back to you in a bit thanks for the help everyone.

有幫助嗎?

more options

Thank you both for the help, after doing what FredMCD outlined no plugins have been disabled again. So either it is a coincidence and something else has changed or is not happening anymore or there was some corruption in the files as suggested. Nevertheless it seems to have solved my problem so I've marked it as the answer. Thanks again guys.

有幫助嗎?

more options

This has now happened 3 more times since my previous post, so it seems deleting the files does not help with the issue but rather resets firefox thinking they are bad. If there are any other suggestions I'd love to try them.

有幫助嗎?

more options

Here's something else. Have you down this same usage with the computer in SafeMode with Networking and running FF with addon disabled and see if the same issue happens again? I don't see mentions of trying SafeMode here?

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題