搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Drop-down menu not offering options to make selection

  • 29 回覆
  • 1 有這個問題
  • 104 次檢視
  • 最近回覆由 FredMcD

more options

Hi,

I'm having a really strange problem.

I'm using Firefox on WIN 11 with my new LG laptop.

When I access a website's drop-down menu, it does not offer me options that I can make a selection.

I know that it's missing the 2 options - because when I try it on other PCs - it works fine. So the behaviour is different (and works) on other computers.

And the stranger thing is; it also does not offer the options when I tried it with Chrome and Edge.

I tried clearing the history and cache - and it still gives the same behaviour.

I called the Tech Support of the website - and they said it's clearly a problem with my specific PC. I would tend to agree with them - because I can access their site without any issues on other PCs.

I can't figure out what's in common amongst the 3 browsers I tried on this LG laptop. The only thing I found in common is this laptop!

Any ideas - any thing I can try next? Really driving me nuts...  :)

mjl

Hi, I'm having a really strange problem. I'm using Firefox on WIN 11 with my new LG laptop. When I access a website's drop-down menu, it does not offer me options that I can make a selection. I know that it's missing the 2 options - because when I try it on other PCs - it works fine. So the behaviour is different (and works) on other computers. And the stranger thing is; it also does not offer the options when I tried it with Chrome and Edge. I tried clearing the history and cache - and it still gives the same behaviour. I called the Tech Support of the website - and they said it's clearly a problem with my specific PC. I would tend to agree with them - because I can access their site without any issues on other PCs. I can't figure out what's in common amongst the 3 browsers I tried on this LG laptop. The only thing I found in common is this laptop! Any ideas - any thing I can try next? Really driving me nuts... :) mjl

被選擇的解決方法

From the Syntax Error, it sounds like the WebResource.axd file is loading, but is somehow damaged.

That also could explain the reference error, if Firefox disregarded the rest of the WebResource.axd file after the syntax error.

What isn't clear is why 3 different browsers should have the same problem. There must be a common factor, such as a proxy server or filter through which the web requests are retrieved.

I assume you already tried rebooting this computer?

The iPad test suggests that it's not your router, but you may want to try rebooting your router(s) in case something has gone wrong there.

從原來的回覆中察看解決方案 👍 0

所有回覆 (20)

more options

Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

有幫助嗎?

more options

Hi FredMcD,

Thanks for your suggestions, I really appreciate it.

Unfortunately - it didn't quite solve the problem. But I think I'm getting closer...

When I tried to view your first link re. enhanced tracking protection, it didn't show any images within the Firefox page. It was missing all the screen captures that's used to illustrate what to do.

I know this - because I also looked at the same link on another PC (which does NOT exhibit the original drop down menu options) and the page showed up properly displaying the images.

I'm guessing this is related to my original issue. What's causing this to happen?

Back to the original problem. I reviewed the setting for enhanced tracking protection. It's set to "standard".

Also - I tried same sequence in Troubleshooting (Safe) Mode and problem also continues to happen.

Finally - I cleared cookies, cache and history. Problem still happens.

Any other thoughts? Thanks.

mjl

有幫助嗎?

more options

有幫助嗎?

more options

OK - so I've created a new profile and launched it to a new Firefox window.

I log into the website in question - and the problem is still there.

By the way - I know this is a forum for Firefox issues, but I also want to mention again that I tried using other browsers (such as MS Edge and Google Chrome) and the problem also shows up there. I'm thinking that there is "something" in common with the 3 browsers I'm using on this new PC that is causing it. I just don't know what...

Another observation. I wanted to do a screen capture of the issue and add it to this chat. But it won't let me. When I click Browse - to Add images, it opens another window and offers me the files to load up. However - when I select the image of the screen capture - nothing seems to happen. The image is no included with this message.

I'm going to need a bit more help...

Thanks.

mjl

有幫助嗎?

more options

Please use imgur.com or a similar image host in the future if the image appears to hang on upload

I called for more help.

有幫助嗎?

more options

Thanks Fred.

Just for fun - I just tried another different browser - Opera. Same result, drop down menu doesn't give me a list of options to choose from.

This particular problem, in and of itself is not so significant - because I can just use my other PCs to access the website. But - I'm thinking a bit more broadly now. What other issues with my browsing experience that I'm not aware of - can this problem cause?

Maybe I'm missing a setup or configuration with my PC in general. After all - it's a newly bought PC working only for a couple of weeks. And the issue happens when I tried four different browsers on this PC.

Again - much appreciate your time.

mjl

有幫助嗎?

more options

Are the missing menu items generated (or revealed) based on other factors? For example:

  • only when logged in
  • geographically restricted
  • based on previously set preferences stored in a cookie

Do you use the same security software on both system with the same access rules?

Could you observe whether requests are missing or blocked in the Network Monitor. You can open that in the lower part of the tab using Ctrl+Shift+e. When you reload the page, Firefox should start listing all the files it is requesting, along with information about whether the request was successful. Any pattern of blocked requests?

有幫助嗎?

more options

Jscher2000,

The missing menu items are specific to my account. I need to login first, before going to this step to use the drop down menu. I should add that not all drop down menus on this site have this problem. There is a previous step with a drop down menu that works and offers the proper choices to select.

I don’t think it geographically restricted. But it may be set preferences stored in a cookie because it needs to know that I’m the specific user who logged in.

The security software is the same and after comparing the settings, they are also the same.

I should also add that I’ve used a laptop from work, with totally different security software and I don’t experience any problems.

I will need to get familiar with the Network Monitor tool and do some side by side comparisons between two PCs. It looks like a fantastic tool, and I’ll need to figure out what to expect first in a working PC and then see what, if anything, is missing with the problematic PC.

Let me get back to you, thanks for suggestion.

Mjl

有幫助嗎?

more options

Ok - I've used the Network Monitor tool.

I tried it out on a working PC and compared the results to the problem PC. As far as I can tell - the network traffic from both Firefox browsers are the same. Each time I press a button (on each browser) - the very same messages were displayed.

Not sure what else I can try.

Actually - I did try it with an iPad using Safari and there's no problem. Worked like a charm!

Just this one (new) PC using 4 different browsers shows the problem.

mjl

有幫助嗎?

more options

If it's cookie-based, it would be difficult to compare between desktop and mobile browsers. Perhaps you can compare between your different networks. In Firefox, you can call up a list of cookies and local storage items for a page using the Storage Inspector (Shift+F9).

I'm trying to think about what else might be different on a new PC. Parental control filters at the OS level?

有幫助嗎?

more options

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

有幫助嗎?

more options

Hi jscher2000, cor-el:

Thank you for your replies and ideas to solving this problem.

I just want to add a recent update:

I've found yet a second website - not working properly. This one does not require me to login to an account.

The website is: https://www.promo-trak.com/SelectOffer.aspx

When I reach this site - it shows "Select the Rebate To Redeem". On the new PC with the problem - it just shows this title and nothing to select. On a working PC - it shows the same title, along with "NexGard, NexGard SPECTRA and COMBO" Rebate Offer.

I did try to use the "Forget About this Site". Unfortunately - it did not appear to make any difference. I was still not able to see the option to select a rebate offer.

On two other PCs in my home - this site worked well.

This second website also does not work using Chrome nor Edge browsers.

I'm going to read up about the Storage Inspector and get a better understanding of how that works and what to expect. Will report back on those findings.

If anyone can think of anything else - I'd appreciated.

Thanks.

mjl

有幫助嗎?

more options

So - here's another interesting behaviour that is probably related....

When I tried to Add images (screen caps) to this dialog - I am unable to. I hit the Browse bottom below, another window opens up to allow me to select the image. I then select the image and hit open, and then the window goes away. Yet - nothing is attached to this dialog.

So ironically - even the Firefox support page isn't working properly.  :(

I verified this "Add images" functionality on another PC and it works. It allows me to add screen captures/images.

mjl

有幫助嗎?

more options

Note: If you have problems when uploading the image to this forum, you can use imgur. com or a similar image host if the image appears to hang on upload, then add a link to the image. However, this may delay a response if the external link needs review by a moderator.

有幫助嗎?

more options

The promo-trak page doesn't work for me as well in Firefox, so it looks it is currently broken if it worked before.

有幫助嗎?

more options

Yes - it looks like this link is broken right now.

But here's another variation of the same website that works for me on a good working PC:

https://www.promo-trak.com/SelectOffer.aspx?cn=NexGard-Spectra

I've managed to attach 2 screen caps to show what I got from the good working-PC.

I will do this again on the bad problem-PC in the next post.

有幫助嗎?

more options

Here's a screen cap from the bad, problem-PC.

When I hit the button "Submit this rebate" - nothing happens. It does not take me to the next page - "Terms and Conditions".

有幫助嗎?

more options

Here's screen caps from the working-PC. I'm not a coder so I don't really understand what these messages mean. I thought I'd share it with you - to see if you can tell what's going on.

From working-PC.

有幫助嗎?

more options

Here are screen caps from the problem-PC.

有幫助嗎?

more options

As I said - I'm not familiar with the details of how Firefox works. It looks to me that the messages are the same between my working-PC and problem-PC.

Am I at least looking in the right place? What other tools should I try?

有幫助嗎?

  1. 1
  2. 2
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題