搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox using 50% of CPU

  • 7 回覆
  • 1 有這個問題
  • 1 次檢視
  • 最近回覆由 CJ1998

more options

Since at least last week (3/28/2022) Firefox has been running in the background utilizing at least 50% of my CPU, hurting performance in my PC games. I've checked settings and "About Mozilla Firefox" and both say "Firefox is being updated by another instance". Ending the process doesn't close the browser, and it will usually function fine for a little while, before resuming again.

Since at least last week (3/28/2022) Firefox has been running in the background utilizing at least 50% of my CPU, hurting performance in my PC games. I've checked settings and "About Mozilla Firefox" and both say "Firefox is being updated by another instance". Ending the process doesn't close the browser, and it will usually function fine for a little while, before resuming again.

被選擇的解決方法

If Firefox creates a new profile then it is possible that there is a problem with the profiles.ini. When you create a new profile then this profile should be registered in profiles.ini, so that Firefox can find it on the next start. You can find the profiles.ini file in a hidden location:

  • Windows: %AppData%Mozilla\Firefox\
    C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\

Note that Windows hides the .ini file extension by default. Also do you double-click this file, but use the right-click if you want to inspect the file in e text editor (Notepad).

You may have to cleanup unregistered profiles you do not use or can't use. Firefox uses two locations for the Firefox profile folder. One location for your personal data (e.g. bookmarks) and another location for temporary files like the disk cache.

Location used for the main profile that keeps your personal data (Root Directory on about:profiles).

  • C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile>

Location used for the disk cache and other temporary files (Local Directory on about:profiles).

  • C:\Users\<user>\AppData\Local\Mozilla\Firefox\Profiles\<profile>
從原來的回覆中察看解決方案 👍 0

所有回覆 (7)

more options

I've refreshed and reinstalled Firefox with no luck.

more options

What is the startup path of those Firefox instances if you enable that column ?

You get "Firefox is being updated by another instance" when there is another Firefox instance open that use a different profile folder.

How many profiles do you have if you check this on the hard drive and in the profile manager or the about:profiles page ?

more options

Thanks for the response, I've removed the other profile from profile manager and the data off of the hard drive. Currently looking good, but I'll update if this shows up again, or close this if it remains solid for a day.

more options

Looks like the problem continues to persist. Firefox appears to constantly create a profile named "user" every time I restart the PC. I apologize, I don't know too much about browsers.

more options

選擇的解決方法

If Firefox creates a new profile then it is possible that there is a problem with the profiles.ini. When you create a new profile then this profile should be registered in profiles.ini, so that Firefox can find it on the next start. You can find the profiles.ini file in a hidden location:

  • Windows: %AppData%Mozilla\Firefox\
    C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\

Note that Windows hides the .ini file extension by default. Also do you double-click this file, but use the right-click if you want to inspect the file in e text editor (Notepad).

You may have to cleanup unregistered profiles you do not use or can't use. Firefox uses two locations for the Firefox profile folder. One location for your personal data (e.g. bookmarks) and another location for temporary files like the disk cache.

Location used for the main profile that keeps your personal data (Root Directory on about:profiles).

  • C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile>

Location used for the disk cache and other temporary files (Local Directory on about:profiles).

  • C:\Users\<user>\AppData\Local\Mozilla\Firefox\Profiles\<profile>
more options

It looks like that fixed it, thanks for your help!